BORON was working now flashing Green

I have had a Boron for about 6 months and built an Asset tracker with the GPS module and OLED display. The device worked great for about 4 months and I brought it back to the lab for some enhancements. I ended up not getting to it for about a month, and when I plugged it in (battery was dead), it would not connect to the LTE network and keeps flashing green. I tried to refresh the firmware through the CLI but keep getting the error “Error writing firmware: Transfer cancelled” even if I flash a simple Hello World firmware to it.

I’ve also tried re-provisioning it with the IOS app but it fails after the SIM activation. I checked the SIM on Particle Cloud and it shows as active.

I read a post that the Boron can brick if it loses power? I find that hard to believe?

Thanks,
Sachin

I’m having identical problems with two borons, except no errors while flashing fresh firmware or updating.

Anyone have any luck, movement, or help from particle on this?

Hello to you both! It’s so much easier for us to diagnose flashing green (no connectivity) issues in the context of a support ticket. First - please see our Cellular Connectivity Guide (https://support.particle.io/hc/en-us/articles/360044518213) for first steps in order to do so!