Boron Power Issue with Sharp Dust Sensor

I’ve run into a power issue with my Boron. This is the first time using this board so bear with me if this is a simple problem. I’m building a dust sensor project running a Sharp GP2Y1010AU0F specifically this one. Im trying to run it off the 3.3v pin on the Boron and when I power it up with a USB cable the sensor shows power but the charge status LED turns onto orange and doesn’t change and the Status LED doesn’t do anything. I previously ran this on a Photon and had no problems.

I’m guessing this is a power draw issue but the Boron should be able to supply more current than the photon so I’m not sure what I’m doing wrong. Any ideas what I can do to fix this?

Thanks in advance!

A lit charging LED would indicate it is charging.
However, depending on the current remaining after powering all your connected circuitry may be quite small and hence you won’t see the SoC of the battery change over a really long period.
Also, how much current can your USB source deliver?

Are you powering the sensor from the 3v3 pin?
Then yes. But the current a GPIO can drive on the Boron is less (14mA) than on the Photon (25mA).

This sensor requires 20ma according to the specifications. So if it is powered from a GPIO pin you have an issue, if its powered from the 3V3 directly - then there is something else wrong. Perhaps post some pictures of how its connected?

Does the problem appear if the module is NOT connected at all?

1 Like

Thanks, ScruffR and shanevanj for the help.

Here is a picture of what I’m trying to do. The sensor has VCC plugged into the 3v3 on the Boron, GND to GND, AOUT to A0 and ILED to D6.

Im connected to a Macbook Pro with USB C so to my knowledge that should be plenty of current for the Boron and the sensor.

Yes I’m supplying the sensors VCC pin with the 3v3 on the Boron. I also do have the ILED pin on the sensor connected to a digital io pin but it shouldn’t be drawing current when I first plug in.

The minute I unplug the sensor the boron enters its normal boot-up process.

I cannot vouch for USB C, but for USB 2.0 and 3.0 a USB device should start off with a max. current demand of no more than 100mA and then negotiate it’s actual need.

Have a try with a USB charger and see whether anything changes.

Just tried it with a 12w usb charger and still running into the same problem.

Try only unplugging partially - keep Vcc and GND and only remove ILED and/or Aout and see what each of the three cases does.

Try connecting a LiPo too.

The sensor cable seems to have female connectors, try them directly on the Boron without the breadboard.

Just had some success. I tried unplugging both the ILED and Aout neither of which helped. But I just plugged into a LiPo and it has booted up and everything seems to be working properly.

Any idea why this would be?

When the LiPo helps I’d suspect there is a sudden current spike when the system is plugged in which can’t be met by the USB supply fast enough. LiPos are much more responsive.
This is a known issue with 2G and 3G Electrons which can’t be used reliably without LiPo or extra fast USB/Vin supply.

1 Like

Interesting, ok. I was originally hoping to run the system without a lipo and instead use a small AC-DC stepdown connected directly to the VBUS pin. I’m guessing if that isn’t fast enough I’ll need to add a supplemental Lipo.

Thanks so much for helping me figure this out.

You can also add some buffer caps instead, but for that you may need to experiment which and how much capacitance you need.

I didn’t even think of that, but that makes sense. I may end up trying to do that then.

You could also try a better power supply.
I’ve had good luck with these 5V, 2A, (has the micro USB connector already), for Boron LTE’s without a Li-Po.

But since you mentioned you plan to land the input source on the Vusb Pin, you also have the option of using a 12V power supply (instead of 5V) for additional operating margin. With a 12V supply, changes to the Device OS firmware would have less chance of impacting the Boron in the future.

Thanks for that link. Depending on how the supply I was hoping to use works, I may switch over to that.

Can the Boron take a 12v input thought? I thought the Boron had a max input of 6.2v. Im assuming you’d then need a voltage regulator.

Yes. A quick search revealed a few Posts on the forum related to this:

OK well, that might be the move then. Thanks

One other thing you could try with your current USB supply.
What when you use SYSTEM_MODE(SEMI_AUTOMATIC) and wait a short while with spinning up the cellular modem?
This way you could have two smaller power surges instead of one big one immediately.

2 Likes

I will definitely be trying that. That would make solving this especially easy. Thanks!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.