Boron debugging using Jlink


Anyone tried debugging boron using jlink swd?

thanks in advance


Hi there and welcome to the community!
is it the Particle debugger you are talking about?

Yes, it should be possible to debug Boron applications using the Segger J-Link in SWD mode.

We only have official instructions for the Particle Debugger (CMSIS-DAP) but the debug build files generated by Particle Workbench or gcc-arm should work the J-Link either with OpenOCD or with Segger Studio. But it will require some effort as there are no instructions for doing so at this time.

No, I am looking a way to debug the Boron using a J-link

Thanks rick,

Yes, I was trying a way to build a debug configuration with VS code studio for debugging via jlink, I see a way doing from this post but not yet seceded, I will keep posting if I have any break through.


I have added new debug configuration

When I run the debug I get the following error “Failed to launch undefined GDB Server: Error: spawn JLinkGDBServerCL.exe ENOENT”

Its clear the VC code is not able to get the path for JLINK GDB executables, but not sure how to feed it.

There is break through, I am able to attach attacheh the JLink debugger and load the binary, following settings are missing in workspace.json and launch.json files which enables to debug via jlink.

But I still have issue in stepping through the code, after loading the binary I am struck at startup_nrf52840.S.


You need to add:

"rtos": "FreeRTOS"

to launch.json in order to be able to step into FreeRTOS code. I’m not positive that’s the failure you’re seeing, but it could be.

After adding ‘rtos’, its not even hitting at startup_nrf52840.S.