Blinkled not working on local build


#1

Hello Community
For a project at University I am using the particle photon. In a later stage of the project I will use a custom firmware and so I can’t use the particle cli. I am building locally and flashing with dfu. Now i followed the tutorial on local building: https://docs.particle.io/faq/particle-tools/local-build/core/
It all works just fine without any errors BUT when i flash the photon with

make all PLATFORM=photon program-dfu APPDIR=../../blinkled

I get no errors and it seems to download fine. But when my photon resets from dfu mode and starts it doesn’t seem to execute my code. I have tried to run the blinkled example from https://docs.particle.io/guide/getting-started/examples/photon/#blink-an-led.
Does anyone have an idea what I did wrong?
Thanks in advance
Fajak


#2

Hi Fajak93,
I just got it working this afternoon on my Mac. I also used the blinkled example. The problem I had was I needed to add the '#include “application.h” ’ line when blinkled.ino was changed to blinkled.cpp.

I saw that you did a:

make all PLATFORM=photon program-dfu APPDIR=…/…/blinkled

which did not work for you. I did a make with the following:

Then I flashed it through WiFi update where photon LED was “breathing” cyan:

This worked for me. You might also try other methods:

A. Device is in DFU mode blinking yellow

OR

B. Device is in Listening mode blinking blue

These also worked for me.
Good luck


#3

same question here. So I follow the example building locally by gcc-arm toolchain in OS X. When I was trying to do


but the the outcome is
as @fajak93, I just use the first example in blinkled.cpp. I thought the reason it does not work because blinkled.cpp cannot be compiled, then add #include <application.h> at the beginning of it. However, it still doesn’t work, even I tried just arm-none-eabi-gcc-4.9.3 blinked.cpp , it shown

⇒  arm-none-eabi-gcc-4.9.3 blinked.cpp
blinked.cpp:13:25: fatal error: application.h: No such file or directory
 #include "application.h"

So I am not sure which part I did wrong, do I need to make the blinked folder structure as a project structure which including necessary libs?

Any advices?
Best Regards