Asset Tracker V2 help - no GPS fix


#1

I’m having trouble getting a GPS fix with a new asset tracker (V2). My code is below. Every minute my event log records a ticker update, and the GPS update returns “No Fix”. When I call the “gps” function, it returns “0”.

The GPS antenna isn’t blocked, and I’ve tested it both indoors and outdoors.

Does anyone know if this is a code problem, or maybe a hardware problem?

Thanks

//CODE
#include <AssetTracker.h>
#include <math.h>

AssetTracker t = AssetTracker();
FuelGauge fuel;

int led = D6; // This is where your LED is plugged in. The other side goes to a resistor connected to GND.
int ticker=0;

void setup()
{
	Particle.variable("ticker",&ticker, INT);
	Particle.function("gps", gpsPublish);
    
    t.begin();
    t.gpsOn();
}

void loop()
{
	ticker = ticker+1;
	delay(1000);
	if (ticker % 60 == 0) {
	    
	    // Ticker message to confirm particle and publishing is working
	    String Message = "Time = " + String(ticker/60);
	    Particle.publish("Minute",Message);
	    
	    // Turn on GPS, Update it, and publish location
	    
	    t.updateGPS();
	    
	    if (t.gpsFix()){
	        Particle.publish("GPS", t.readLatLon(), 60, PUBLIC);
	    }
	    else{
	        Particle.publish("GPS", "No Fix");
	    }
	}
}

int gpsPublish(String command) {
    if (t.gpsFix()) {
        Particle.publish("G", t.readLatLon(), 60, PRIVATE);

        // uncomment next line if you want a manual publish to reset delay counter
        // lastPublish = millis();
        return 1;
    } else {
      return 0;
    }
}

#2

You should try the AssetTrackerRK library and start with the 1_SimpeGPS example there.


#3

Thanks for the advice. I set the device outside and I’ve been running the 1_SimpleGPS for 18 minutes. But every 2 minutes I get a “no location” message. Any other troubleshooting ideas?


#4

Do you have a clear view of a big portion of the sky to actually get contact to min. 3 satellites?
Tall buildings around your location may obstruct the signal.

You could also try the 7_DataDump sample and see what the GPS module spits out.


#5

Thanks for the reply. Yeah, it’s sitting in an open backyard, a few trees around the perimeter, but mostly open sky. No tall buildings in the area - just 2-story suburban houses.

I tried 7_DataDump, let it run for 20 minutes, and I’m getting the same results…every 2 minutes I got a “no location” message.

Any other ideas?


#6

might want to try carefully unseating/seating the electron a few times and i’d try an additional battery for the tracker for testing. you could also install a gps app on a cellphone or gps enabled tablet to have along side the tracker just for verification that required sat. mix exists.


#7

You should monitor the serial output of that sample to get some more background info of what’s happening with the satellite communication.
If you can’t make sense of that you can post that output here.


#8

I pasted the serial output below…I don’t know how to make sense of it. That sequence repeated every second.

Also - I tried unseating/seating the electron on the GPS and finally saw the GPS FIX LED flash for the first time. Now, I see it flash upon reset only, and once the 7_DataDump is running, I never see the GPS FIX LED blink.

Thanks for the continued help.

SERIAL DUMP:

13:55:50.685 -> 
13:55:50.685 -> $GNRMC,,V,,,,,,,,,,N*4D

13:55:50.685 -> 
13:55:50.685 -> $GNVTG,,,,,,,,,N*2E

13:55:50.732 -> 
13:55:50.732 -> $GNGGA,,,,,,0,00,99.99,,,,,,*56

13:55:50.773 -> 
13:55:50.773 -> $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E

13:55:50.819 -> 
13:55:50.819 -> $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E

13:55:50.886 -> 
13:55:50.886 -> $GPGSV,1,1,00*79

13:55:50.886 -> 
13:55:50.886 -> $GLGSV,1,1,00*65

13:55:50.886 -> 
13:55:50.886 -> $GNGLL,,,,,,V,N*7A

#9

check this thread,

and this one,

if you have access to an external antenna then try attaching that or create support ticket.