Argon Wifi mbed OS

I am trying to connect device to wifi network. But I use mbed OS framework instead of Device OS.
The Argon datasheet indicates that esp32 is connected to nrf52840 as follows:
“wifi-en”: “P0_24”,
“wifi-tx”: “P1_4”,
“wifi-rx”: “P1_5”,
“wifi-rts”: “P1_6”,
“wifi-cts”: “P1_7”
In the datasheet, there is only no information to which pin wifi-io0 is connected.
I used this driver https://github.com/ARMmbed/esp32-driver
But when I output information about the mac address to the terminal, I get 0

ESP32Interface * wifi = new ESP32Interface (P0_24, NC, P1_4, P1_5, false, P1_6, P1_7, 230400);
printf ("mac =% s", wifi-> get_mac_address ());

I tried to specify P0_16 or P0_7 instead of NC for the wifi-io0 pin, but the result is the same.
Please tell me what could be wrong.

This is not a supported use-case, so you’re likely to run into any number of issues.

However, that information is in the schematics. ESP32 IO0 is the boot pin, connected to net BOOT_W.

That net is connected to the nRF52 pin P0.16.

2 Likes

I connected to esp32 board, connected to wifi and got ip address, but I don’t know what AT command I can send to get this IP. I tried AT+CIFSR=? but I got answer AT+CIFSR=?
ER CODE:0x01090000
Help me please

Not sure. I believe that Device OS on the Argon uses the ESP32 in CMUX (GSM 07.10) mode so it probably never issues an AT command to find the IP address. I didn’t see anything in the source.

1 Like