Argon Featherwing issues

I have been doing basic operations with the Argon for a while with great success.

I recently took the plunge and got 3 feather wings and im having nothing but trouble getting the libraries people have posted here to work.
Color TFT with Joystick
32u4 Adalogger
DS3231 Precision RTC

  • I got the TFT one to compile after fixing some Arduino related code but it still would not display anything even with using the display test function
  • I cannot get the Adalogger or RTC to compile at all. Does the RTC have to have the battery in it to function?

I have tried each of them solo on a doubler with the Argon. I have also tried them all stacked.on the doubler together.

Once this comes together it will be great but until I can find working libraries, I’m stuck. I’ll try to re compile them now and copy the results.

Thanks.

Welcome

You will need to give us more info and how you plan to use the finished combination?

The datalogger is nonparticle product and you may need to seek support in Adafruit learning system. It is unlikely that using a argon and 32u4 plugged into a doubler will work as the pin outs may clash. You need to define how one will work with the other and then connect them accordingly

2 Likes

To expand on @shanevanj’s assertion regarding Argon vs. 32u4 Adalogger: Both boards are meant to be “masters” on the system as both do feature their own micro controler.
Usually you’d only have one controler in a doubler/trippler and some “client” FeatherWings - but here you’d have two would-be masters which you’d need to program separately to make them cooperate (if at all possible in case of pin incompatibilities).

1 Like

I use many of the DS3231 Precision RTC Adafruit boards - there should be no issues there although I remember there was a fault in the library I had to correct. If you do hit an issue then please make a specific post on that and I will share.

An alternative to the 32u4 Adalogger would be to use the Adalogger (this combines a micro SD and a PCF8523 RTC) and is a slave I2C device for the RTC and SPI for the micro SD. You then might have a conflict with the Color TFT with joystick because of the SPI chip select pin usage.

1 Like

Good point. I have another data logger on the way.

It did not occur to me at the time of ordering that the original board would have a fully functional MC on it as well.

Yes this is the board I have on the way.

Thanks for the help. I’ll try the RTC on its own next and see what I get.

Here is a link to the thread with the fix to the DS3231 library. Adafruit 3028 DS3231 RTC Problem

2 Likes

Once I get my device to boot up off network, I’ll try this. Thanks