Android Serial and Photon problem

Hi particles,
Really strange problem with serial and Android. I have for months been using my Nexus 7 tablet and OnePlus Android phone as serial monitors for my Photon. The physical interface is a USB A to mini, an OTG adaptor and an Android program called Serial Monitor Lite. It has just stopped working with the Photon, but works fine with Arduino. I have changed all components, reloaded the Android app and tried a different Photon - same result. I have also tried different Android apps. I have connected the photon to a PC and have no problem reading serial with the Arduino IDE setial monitor, or realTerm. Anyone got any ideas, or advice as to why the Android interface suddenly stopped working?

1 Like

Is your Photon serial port listed in your tablet?

1 Like

I’m not sure how to find out. I’ve done some googling on how to identify serial devices on Android but nothing useful. Is there a simple way to find out?

Don’t you need to select a device for the serial monitor? Sorry im not familiar with using Android to view serial monitor. :slight_smile:

No, with android you use an adaptor called OTG, once inserted in the micro USB port of your tablet Android recognises it as a device. Its mostly used for USB memory, mouse or keyboard interface. This guy did exactly what I was doing USB Android Serial and until recently it worked fine

@DRCO did you recently update your Android version? In the thread you linked the OP talks about it working with 4.4 (KitKat), but not on Lollipop.

1 Like

I’m running marshmallow 6.0.1 on both phone and tablet and have been for months, during that time serial monitor lite worked fine .that’s why I am trying the particle forum - thinking maybe something has changed in the photon firmware. I always flash using latest build. Maybe I should try going back a few versions?
I tried flashing my photon with build 4.7 and 5.1 - no change. I guess that rules out the problem being with Photon. Android regularly has security updates without changing the OS version so I guess that’s the most likely place to look.

1 Like

@DRCO I haven’t tested mine for a while, but you could look at this and see if things have changed. This App tells a bit about the serial connection.

When I did it the photon settings were
vid: ‘2b04’,
pid: ‘c006’

I also had problems above Android version 4.4. It is worth looking into a fix since the photon as a dongle is a fairly powerful combination since it still has it’s wifi capabilities and the Android device can also be a hotspot!

1 Like

OK, now this is strange but suggests something has happened on the Android side. I had a recent update on a security patch for both devices. I had a little time and decided to revisit this problem, starting with @rocksetta 's advice to test the device information. Anyway, long story short - when I hooked up my Nexus device and checked Android Serial Monitor lite - it worked fine. Not so on the OnePlus One device.

So the good news is, if you want to use this pretty handy Android app - it works, on some devices.

Thanks to anyone who responded.