Am I Doing Something Wrong?


#4

Hi ScruffR,

Here’s one image I got just now by trying to manage libraries. I’ll have to play around a little more to recreate the other error messages.

Thanks for replying


#5

I don’t see a file tree in the left hand panel.
Try to open a project folder, or use the create project icon on the left hand side.
It also seems you have hidden your menu bar.

Try Alt to show the menu bar, then you’ll be able to select File - Open Folder …


#6

Good morning gusgonnet.Thanks for replying.
I’ve had a good night’s sleep, and now it’s time to tackle this again!
Actually, I started out with the web IDE; that’s what led me to Particle Dev. Maybe if I told you my whole story it might help explain why I’m doing this and perhaps you could guide me what I need to do.

  1. Two months ago I got the brilliant idea I wanted to build a bubble tube. I found a good tutorial on the web that I thought would walk me thru it without any problems (http://www.morphatic.com/category/diy/). I bought all the exact parts mentioned–even tho I’d never heard of a photon or neopixel in my life. But I was willing to learn! This is where I first got involved with Particle.

  2. I followed all the directions in the tutorial up to building an android app to control the LEDs and motor. This is where I first got lost. However, the tutorial said the ‘source code’ was up on GitHub to use and I thought great, I wouldn’t have to build an app. Hence, this is where my question “how I use this source code??” comes into play. And, the main.ino was not included with the source code, so I tried to build one using the code shown in the picture in part 2 of the tutorial.

  3. After two weeks I got it figured out enough how to open the mobile app on the web with Ionic using the command prompt. And yes, I got it to control the NeoPixel but it’s not controlling the DC motor. I built the breadboard exactly as shown so I know that parts correct.

  4. Now I’m guessing I have to change a few things in this source code to work for me. And that’s how I got involved with Particle Dev.

I tried contacting the author of the tutorial but no response. Meantime, it’s been two months and my bubble tube is still sitting there in pieces until I can get this whole thing figured out. I’m trying to learn about LEDs, Photons, coding, building apps, building pcb boards…and I’m stuck on stupid. I must admit I’m getting really burnt out with this whole IoT thing…if it wasn’t for all the money I’ve spent on it.

And that’s my story. Wow, that felt like a load off my chest! I fully understand if you can’t help me any further and I thank you for your suggestions thus far.
slarja


#7

Hi @slarja, Thanks for posting you thoughts. I agree that there needs to be a few video "how to…"s made. @ScruffR would be a good candiate for that job :wink:
Your project looks super cool and I am sure there is easily enough resource here in the forums to get you up and working.

Your feedback is valuable and valued. Most people here have been at this for years and it is second nature to them. A fresh pair of eyes is a good thing.

`#thesimplequestionsarethepowerfulones

Good luck, keep at it. Please post photos when it is complete.


#8

Unfortunately I can’t do that right now because I’ve uninstalled both particle-dev and atom. Now that I know it’s an extension for atom I thought I’d start over; install atom, then get particle-dev thru the install packages part. Does that sound right? I haven’t done it yet, will wait for your feedback. Seriously tho, there was no mention on the particle.io website that said it was an extension to atom and not a standalone program. That might be an important piece of information they might want to include…

Oh, I saw on GitHub a new version of the particle-dev package 0.1.20. I downloaded it just for the heck of it and that brings me back to my original question…How do I install it from this source code folder???


#9

If you download the Partice Dev installer, it will bring all the dependencies - including the Atom base app - just fine.
Hence there is no need to mention Atom explicitly IMHO.


#10

Yep, that’s the same file I downloaded and installed the first time. Same problems. I must say my level of frustration is thru the roof. I’m quickly becoming Jack Nickelson’s character in ‘The Shining’! So just for giggleshits, I thought I’d try installing it with the method I mentioned before. Here’s a screenshot of how that went:

And I might mention I uninstalled Particle-Dev again, before trying this method. If you haven’t seen it yet already, check out my reply to gusgonnet, that tells it all.


#11

There seems to be some issue with the node version on your machine.
@tylercpeacock, you think Wojtek could help out here?


#12

Thanks for your support Julian. I will certainly post that photo if I ever get it working. But there’s a good chance I’ll die of old age before that happens!


#13

I remember reading something about node.js v7.1 didn’t work right with something…so I installed v6.10.3 if that helps any.


#14

Oh goodness, this does appear frustrating. Yeah, I’ll try and get Wojtek in here to take a look at this as he would have the best insight. Hopefully we can clear this up quick!


#15

@slarja, you already had the captain, looks like the whole cavalry is on their way.

“Oh goodness, this does appear frustrating. Yeah, I’ll try and get Wojtek in here to take a look at this as he would have the best insight. Hopefully we can clear this up quick!”

They will get it sorted !

Just stick with it :slight_smile:


#16

I don’t think there is any chance of you “moving on” before you get it working. That said, how old are you??? :joy:

Seriously though, these guys will get you up and running. I am confident.


#17

…Now I’m curious too. How old do you think I am? What is your ‘perception’ of the person your communicating with??


#18

@slarja, Hi, I have no idea how old you are. You could be any age. pre teens to post retirement on here,all welcome all with a skill set to share. I was just making a (poor) joke about how long it might take to get your project up and running.I am sure it won’t be long though. No offence intended, I apologise unreservedly if you were.


#19

No apology needed. No offense taken. I apologize to you if you think I was upset. Actually, I found it amusing; it was the first time I smiled in days!


#20

@slarja,

Good. Now where are you stuck? How can we move you forward? @tylercpeacock is Wojtek on this?


#21

Well, I’m stuck in more than 1 place. Atom is still broken so I’ve given up on that. I’d have to say my biggest problem is not being able to control the DC motor thru the mobile app for my bubble tube project. I’m 99% sure the problem is in the code. I’d love to have someone look at it and say either “yes, that should work” or “Nope, far from it”. Maybe you can suggest which forum to post that in? Using the photon for motor control is half the reason I bought it. My only other option would be a potentiometer. Whoopie…


#22

Hi,

You can post the code in this thread. read this post first Forum Tips and Tricks
so you can learn how to post code in the forum correctly.

I don’t want to complicate things but adding a new mobile app adds a level of complexity that doesn’t need to be there. You could use the tinker app, the ITTT red button or Blynk.

Have you seend this project? https://particle.hackster.io/adi1690/particle-photon-motor-control-c1fa6d
It deals with motor control maybe you could use part of this project to get you motor running? :slight_smile:


#23

Hi @slarja :slightly_smiling_face: Particle Dev comes in two flavours:

  • Particle Dev App - a standalone app which contains all necessary packages. If the installer hasn’t worked, you could try the zip file which contains just the app: https://github.com/spark/particle-dev-app/releases/tag/v1.8.0

  • Particle Dev packages installed in Atom - this is the best way to test latest packages and make modifications to Dev. Being a more development approach it has some rough edges. The most common issue is being unable to compile native modules (that’s why we offer the standalone app). You can try installing the toolchain using: npm install --global --production windows-build-tools and then install the Particle Dev app again