Am I Doing Something Wrong?

I’ve got to admit, I don’t understand this program one bit and I’d love for someone to tell me what I’m doing wrong.
I downloaded Particle Desktop IDE (Dev) from the website. From what I gather, the name has been changed to ‘Particle Dev’.

  1. So, I clicked on install, and it did it’s thing, then just disappeared. It took me a long time before I found it buried in the hidden AppData\Local folder. When I opened it up to look around the first thing I did was click on libraries. I got an error message: There was an error while listing libraries. Please try again later. Then I go to settings/Install and every package I tried to get threw out an error message. At the bottom of the list it said: Uncaught Error: ENOENT: no such file or directory, lstat "C:\Users\Slarja\AppData\Local\particledev\app- 1.8.0\atom. The error was thrown from the fuzzy-finder package. Atom is out of date: 1.8.0 installed; 1.16.0 latest. Upgrading to the latest version may fix this issue.
  2. So I clicked on Check for Update, and it says there are no updates! And what the heck is Atom??
  3. So then I went on the web, found and downloaded Atom 64-bit. It installed the same way as Particle Dev without any interaction from me. I too found that buried in it’s own folder in the hidden AppData\Local directory.
  4. So now it’s time to check Particle Dev, and I’ve still got all the error messages! No libraries, the desktop says "Current directory is not a Particle library.

Is it me?! I admit I don’t know anything about coding or making apps; and I’ve been 4 weeks (no exaggeration) trying to figure this stuff out but I’m getting absolutely nowhere. Here’s my major question that I can’t find the answer to: How do you use the source codes downloaded from GitHub?? I understand the cloning and the forking part, thousands of tutorials on that; but I want to know what to do with that open folder staring at me on my desktop! Hence, that’s why I thought I’d try using Particle Dev, maybe something will finally click, but I can’t get past the error messages. Please, if someone could give me a clue on that too, I would gratefully appreciate it. In the meantime, I’m heading for the aspirin bottle!

Hi @slarja ,
sorry to hear you are having trouble with all this.
I am not a Windows nor Particle DEV user, so I cannot say anything about your issues with them.

However, I have a question for you since you mention you wanted to use the source codes downloaded from GitHub. How about you start here:
and work your way into the wonderful IoT world by using the browser-based IDE (called BUILD)?

Note: Atom is a text editor, on top of which Particle built plugins to simplify the coding and flashing of Particle’s dev kits.

Hope it helps!

1 Like

Can you post a screenshot of your full Dev window?

BTW, Particle Dev is actally an extension package of the general purpose Atom editor, hence the “magical appearance” of Atom without having it installed.

In order to have a project or library recognised by Dev, it needs to obey certain rules (folder structure and files in the correct place)

To access the Particle library repository, I think you need to be logged in with your Particle Build account (which isn’t necessarily the same as your community account).

1 Like

Hi ScruffR,

Here’s one image I got just now by trying to manage libraries. I’ll have to play around a little more to recreate the other error messages.

Thanks for replying

I don’t see a file tree in the left hand panel.
Try to open a project folder, or use the create project icon on the left hand side.
It also seems you have hidden your menu bar.

Try Alt to show the menu bar, then you’ll be able to select File - Open Folder …

Good morning gusgonnet.Thanks for replying.
I’ve had a good night’s sleep, and now it’s time to tackle this again!
Actually, I started out with the web IDE; that’s what led me to Particle Dev. Maybe if I told you my whole story it might help explain why I’m doing this and perhaps you could guide me what I need to do.

  1. Two months ago I got the brilliant idea I wanted to build a bubble tube. I found a good tutorial on the web that I thought would walk me thru it without any problems ( I bought all the exact parts mentioned–even tho I’d never heard of a photon or neopixel in my life. But I was willing to learn! This is where I first got involved with Particle.

  2. I followed all the directions in the tutorial up to building an android app to control the LEDs and motor. This is where I first got lost. However, the tutorial said the ‘source code’ was up on GitHub to use and I thought great, I wouldn’t have to build an app. Hence, this is where my question “how I use this source code??” comes into play. And, the main.ino was not included with the source code, so I tried to build one using the code shown in the picture in part 2 of the tutorial.

  3. After two weeks I got it figured out enough how to open the mobile app on the web with Ionic using the command prompt. And yes, I got it to control the NeoPixel but it’s not controlling the DC motor. I built the breadboard exactly as shown so I know that parts correct.

  4. Now I’m guessing I have to change a few things in this source code to work for me. And that’s how I got involved with Particle Dev.

I tried contacting the author of the tutorial but no response. Meantime, it’s been two months and my bubble tube is still sitting there in pieces until I can get this whole thing figured out. I’m trying to learn about LEDs, Photons, coding, building apps, building pcb boards…and I’m stuck on stupid. I must admit I’m getting really burnt out with this whole IoT thing…if it wasn’t for all the money I’ve spent on it.

And that’s my story. Wow, that felt like a load off my chest! I fully understand if you can’t help me any further and I thank you for your suggestions thus far.

Hi @slarja, Thanks for posting you thoughts. I agree that there needs to be a few video "how to…"s made. @ScruffR would be a good candiate for that job :wink:
Your project looks super cool and I am sure there is easily enough resource here in the forums to get you up and working.

Your feedback is valuable and valued. Most people here have been at this for years and it is second nature to them. A fresh pair of eyes is a good thing.


Good luck, keep at it. Please post photos when it is complete.

Unfortunately I can’t do that right now because I’ve uninstalled both particle-dev and atom. Now that I know it’s an extension for atom I thought I’d start over; install atom, then get particle-dev thru the install packages part. Does that sound right? I haven’t done it yet, will wait for your feedback. Seriously tho, there was no mention on the website that said it was an extension to atom and not a standalone program. That might be an important piece of information they might want to include…

Oh, I saw on GitHub a new version of the particle-dev package 0.1.20. I downloaded it just for the heck of it and that brings me back to my original question…How do I install it from this source code folder???

If you download the Partice Dev installer, it will bring all the dependencies - including the Atom base app - just fine.
Hence there is no need to mention Atom explicitly IMHO.

1 Like

Yep, that’s the same file I downloaded and installed the first time. Same problems. I must say my level of frustration is thru the roof. I’m quickly becoming Jack Nickelson’s character in ‘The Shining’! So just for giggleshits, I thought I’d try installing it with the method I mentioned before. Here’s a screenshot of how that went:

And I might mention I uninstalled Particle-Dev again, before trying this method. If you haven’t seen it yet already, check out my reply to gusgonnet, that tells it all.

There seems to be some issue with the node version on your machine.
@tylercpeacock, you think Wojtek could help out here?

Thanks for your support Julian. I will certainly post that photo if I ever get it working. But there’s a good chance I’ll die of old age before that happens!

I remember reading something about node.js v7.1 didn’t work right with something…so I installed v6.10.3 if that helps any.

Oh goodness, this does appear frustrating. Yeah, I’ll try and get Wojtek in here to take a look at this as he would have the best insight. Hopefully we can clear this up quick!

@slarja, you already had the captain, looks like the whole cavalry is on their way.

“Oh goodness, this does appear frustrating. Yeah, I’ll try and get Wojtek in here to take a look at this as he would have the best insight. Hopefully we can clear this up quick!”

They will get it sorted !

Just stick with it :slight_smile:

I don’t think there is any chance of you “moving on” before you get it working. That said, how old are you??? :joy:

Seriously though, these guys will get you up and running. I am confident.

…Now I’m curious too. How old do you think I am? What is your ‘perception’ of the person your communicating with??

@slarja, Hi, I have no idea how old you are. You could be any age. pre teens to post retirement on here,all welcome all with a skill set to share. I was just making a (poor) joke about how long it might take to get your project up and running.I am sure it won’t be long though. No offence intended, I apologise unreservedly if you were.

No apology needed. No offense taken. I apologize to you if you think I was upset. Actually, I found it amusing; it was the first time I smiled in days!

1 Like


Good. Now where are you stuck? How can we move you forward? @tylercpeacock is Wojtek on this?