All of my particle products are bricks now

photon
Tags: #<Tag:0x00007f1cae0cdfb0>

#1

I have used particle core’s and photon’s to automate a couple things around my house, and at my office. I even taught a class at a local university based around the platform. I have always used the web IDE. A couple of the projects that I did less than one year ago using Photons went offline recently, and I haven’t had an opportunity to troubleshoot them. One of my devices, a Core, runs a PID temperature and humidity controlled chamber that I use for various fermentation projects. It stays on 24/7. I remember looking at it on the console within the past few months and remarking how it’s still online just doing it’s job and how robust particle products are.

Yesterday I tried to call a Particle function that is on my Core and it wasn’t working. Light is breathing cyan, but none of the variables or functions are showing up in the console anymore. I tried to verify the code that is currently running on the Core, and the Web IDE threw a bunch of errors that it didn’t throw before. After tracking them down (some of them were quite difficult and time consuming, all turned out to be changes that the Particle team made to rules) and replacing and upgrading all of the libraries to their current versions, I finally got the code to build again, but now it does not fit on the Core. I dropped the Device OS down to 0.7 and it would build but would not flash. At this point, the Core is in an unrecoverable state. Fed up with my Core, I moved to two spare new in box Photons that I had purchased previously.

After several attempts I was able to claim the new Photon and get it to breathing Cyan. Signaling worked, but I could not flash any FW. Downloading CLI and updating the FW did not work and thew and error and caused the Photon to go into breathing magenta. Signaling still works but still I cannot flash any code to this device or do anything.

None of the other photons I have that show as online are correctly reporting their functions or variables. So now none of my particle products work and I have no method to recover or use any of them. Not looking forward to troubleshooting any of the devices that are in my office either.

My experience was: -try to use the particles that were working - all of the code that previously built failed for confusing reasons. All of the older products that I have are bricked by newer software releases from Particle. There is no documentation about getting older products online, or maintaining them correctly besides a few posts on this form of people having similar issues, none of their solutions worked for me.

I don’t think I will use or recommend Particle products from here on out to anyone.

Why should I invest time in building on a platform that needs so much upkeep, and that stops supporting products that are just a couple of years old? Or even worse, releases updates that brick them.

Will this behavior be different with any of the current products?


#2

Hi @davep,

@Dave here! Sounds like this is the first time we’re hearing about the issue? Have you reached out to the support team or posted any other questions about this issue? We’re continuously improving our services and working hard to maintain compatibility and make sure things are working as expected. I hope you’ll give us a chance to look into what you’re experiencing before you write us off completely. :slight_smile:

Thanks,
David


#3

One thing you may want to try for now is to check what device OS version your projects were targeted when you built/flashed them before.

I guess you have your targets in Web IDE set to Default (x.y.z) which will automatically go with the most recent official release, but for cases like yours you can select any legacy version too.

It may also be helpful if you could provide the version info here for support to tackle the issue and better help.


#4

@ScruffR is there any way to find out what OS is running on a core?

Thanks @Dave I’ll give support a shot.


#5

I’ve no Cores anymore to actually test, but you could try particle serial inspect (in Listening Mode) or put the device in Safe Mode and see whether you get a status even published that gives it away, or maybe console.partile.io/devices might show.


#6

@Dave I’m not sure that my issue is the same, but it has similar symptoms and I did post about it a few weeks ago. To recap, all of my cores are no longer showing as connected in the dashboard. On the main dashboard that shows all devices, the cores are shown breathing cyan but as soon as I click on one it goes gray and the details page shows disconnected. Variables are no longer accessible, nor are functions. The cores do publish and I see those publications in the dashboard, but my web apps can no longer connect and/or control these cores.

I originally noticed this condition after upgrading my home WiFi system to a mesh configuration using Ubiquiti amplifi and I suspected that this was the cause. It may have just been when I noticed the issue and not really related at all. I can’t say.

Note that all of my Photons continue to function correctly, even with the new WiFi system. I purchased a new Photon to test this and it works quite well. Whatever this is it appears to be related to cores only. Also, my cores are running rather old versions of the OS 0.4.9 and I am reluctant to try upgrading them. At least they are mostly usable now and I don’t want to brick them.


#7

@Muskie your description of what’s going on with the core matches what I am experiencing exactly. I don’t have any functions publishing anything so I don’t know if that works. I haven’t made any changes to my home wifi. I’ll reset my router to defaults and then try a different network to see if that does anything. It feels like these devices are just no longer supported by Particle. It’s very frustrating because these are a few years old and they were working totally fine, and now they don’t work. I am very reluctant to take the whole project apart to troubleshoot this, and probably brick it since it’s not supported anyway. I’ve spent probably 3-4 hours troubleshooting so far with all of my older devices.

Even more frustrating was that my new in box Photons (which were bought a couple years ago) are also bricks out of the box and even with the CLI tools properly installed, I cannot recover them. Still waiting on help from support.

I get that the resources are concentrated on the new products. But why build on this platform if all of your projects will only last a few years and then an update breaks them? Particle keeps releasing a lot of revisions of new hardware, which is going to make maintaining them all into their old age prohibitive. I get that maintenance is only expected for a certain amount of time, but this is hardware that is installed in my home. I’ve worked as a hardware engineer in consumer electronics for many years. All products I worked on that went into home installations had extremely long maintenance/support lifetimes. If the norm with connected devices is a couple years, it’s going to be really frustrating.


#8

I got both of my Photons working.
List of things that didn’t work after they became stuck in safe mode:
-flash from web ide
-particle update
-particle flash --usb tinker
-particle flash --serial tinker
-particle flash your_device system-part1.bin (followed by part2)

Did work:
particle flash --serial bootloader-0.7.0-photon.bin

Once I flashed 0.7.0, I was able to flash from the IDE all the way up to the latest revision of the Device OS. They still “fail” diagnostic tests that are in the console, but all of the listed tests pass with a green check, so idk what is failing. They seem to work fine.

After that worked, I swapped it for the older Core, and revived that using:
-particle flash --usb tinker

Then I needed to flash several times in a row on the web IDE with 0.7.0 for it to take a flash, but eventually it did, and also seems to be working fine now. Flashing with above 0.7.0 makes my code not fit onto the Core. Flashing blink with 1.0.1 does work on the Core, but none of the diagnostics work in the console.

Hope this helps someone.


#9

So your devices are all working again now?
Did you make sure to update your CLI to the latest version before attempting those commands?
When you say flashing didn’t work using the CLI, how exactly? Were there errors, was it doing something funky?