Adafruit_EPD_RK is out of date

I’ve been struggling for way too long to get the Boron to connect to a 2.9 in E-ink display from Adafruit.

When I try to invoke per the test code here:

Uncommenting these lines:
/* Uncomment the following line if you are using 2.9" EPD */
Adafruit_IL0373 display(296, 128, EPD_DC, EPD_RESET, EPD_CS, SRAM_CS, EPD_BUSY);
#define FLEXIBLE_290

I get an error about setBlack and setColor not being defined, and sure enough they aren’t defined in the older version library.

I tried opening an issue for Adafruit_EPD_RK four or five months ago asking for it to be updated to the latest version from AdaFruit, but I haven’t seen anything from the maintainer.

Can anyone help? I’d love for the adafruit_epd_rk library to be updated so others don’t waste the time on this I’ve spent.


This would be @rickkas7

Sorry, I apparently lost a bunch of Github notification emails. I updated to the 2.3.0 version of Adafruit_EPD.


Thanks a lot @rickkas7, much appreciated - I will give the updated library a spin.

just an update to this - at least on the mesh products - the library doesn’t seem to work. It appears maybe an SPI related issue? Although, putting the library into software SPI mode (not using the SPI interface from Particle) also doesn’t work. (at least for my mono 200x200 eink from Adafruit). also trying ty bypass the SRAM going strait to the eink also doesn’t work.

@rickkas7, is the updated library working for your eink? Which display do you have and which particle product are you using it on?

I just re-tested the Adafruit_EPD_RK library with the Adafruit 2.13" Tri-Color eInk / ePaper Display FeatherWing - Red Black White (4128) on an Argon running Device OS 1.4.4.

It worked properly using primary hardware SPI. I’m pretty sure software SPI will never work reliably, if at all, because of timing issues.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.