Adafruit BME680 WX sensor missing library

The Adafruit weather sensor BME680 library is missing. It was available a couple days ago, any idea?

Are you sure that it’s missing?

Is Adafruit_BME680 not the library you’re looking for?

Well is there, but the content is 0, as a result the IDE is giving me a fatal error: Adafruit_BME680.h: No such file or directory

I can still open the library, see, use, and compile its example successfully for a Photon @ 1.0.0.
Try refreshing the page?

1 Like

Yes, I refreshed the page or cache, still having the same problem. I just tried to compile the example she provides, I get the same error.

Here is a screenshot result of the example she provides:

What device and device OS are you compiling against?

The Redbear DUO, and also I tried the Photon. I get the same result on both devices.

When @Moors7 asked about device OS he wanted to know which version (see bottom right corner of Web IDE - unfortunately your screenshot has cropped that part) :wink:

This is not the content count, but the usage cound (how many projects are using it).
However, that counter is broken/frozen for a while now and I’ve informed Particle about this several times not, so currently it’s best ignored.

1 Like

ScruffR: Thank you for the clarification about the library. Yes, it’s the Redbear DUO firmware or OS version vv.0.3.3

Also I tried a Photon and I get the same result. I am confuse now, I get the same fatal error with some other libraries like Blynk and BME280. So far that’s the only two libraries I have tried and get same error.

The BME280 library, the counter, in this case is not frozen, and so is the Blynk library.

I guess we can consider this topic Solved. However, I may have to open a new one regarding the fatal error I keep getting.

What version for the Photon?

Has the count been incremented when you imported it?
Fronzen doesn’t mean it’s stuck at zero but that it doesn’t increment over time - even if the current cout is non-zero it may be stuck at that count, hence being considered frozen.

No, I dont see the counter increasing. I added the Blynk library, and it was 274.32 before I added, I checked it again after I added, still was 274.32
By the way, I used a complete different computer just in case, and I am getting the same error.

Would you mind answering this question, since that may very well have something to do with the issue:

Thanks!

1 Like

Moors: I tried two devices, the Redbear DUO firmware or OS version v.0.3.3, and the Photon 1.0.0
Both devices report the same issue. They were compiling just fine a couple days ago.