Adafruit 16 x 32 LED matrix only displaying pure red or green

Just hooked up all the libraries developed by @peekay123 and tried running some demos. Text is displaying fine when it’s just red or green only, but blue doesn’t show up at all. If there is any combination consisting of red, the red entirely overwrites any of the other colors. The plasma demo just makes red waves throughout the entire display. We’ve tried writing just blue to the entire screen and nothing comes out at all. Here are some photos from the demo code:

We’re thinking this is possibly a hardware issue - double-checked all the wiring and it looks fine. Any advice would be greatly appreciated :smile:

@blaisezfaire, make sure you are instantiating the correct RGBMatrixPanel instance, ie. the one for 16x32. How did you hook up everything? Can you take a picture of your wiring?

Which libraries are you using? Have you tried the demo apps?

I was not able to get the RGB libraries to work either. I got the same results your seeing.

@RWB, which libraries???

The RGB libraries in the Online IDE.

Your pong clock library worked fine.

@peekay123 here are the libraries we’re using

The wiring is messy but we have all 4 grounds connected (instead of D to A3):

What are you building your code in the first picture? It’s not the online IDE is it?

It’s a desktop program called Particle Dev, essentially a wrapper around the Atom text editor from which you can compile and ‘flash’ code

I see. It looks nice. I have yet to get that up and running :grinning:

You should get it, it’s super easy to set up!

Yea I’m trying to install everything for building locally which requires tons of different programs. I’m almost there :smile:

I have had similar issues of only showing red or red and green with too whimpy power sources.
Give it 2A at least

I was testing with a 5A bench power supply.

But yes that is for sure something to check.

And how about the OP?

We have a 5A supply as well, but perhaps there’s a poor connection there

I’m not saying this is the cause, but I had similar symptoms (loosing blue and mostly green to) due to poor power supply.
But with 5A you should be perfect - other causes to investigate then.

Sorry for the confusion :wink:

Well, we did notice that if the power source is unhooked, it still works… planning on soldering some connections tomorrow, will let you know if that does the trick :thumbsup:

Yea, that happened when only the USB was connected and powering everything which is not enough to fully power the screen so if your not getting that power supply to power the screen then that would probably be the problem.

That happend with the Pong Clock code. Not until it got the 5v 5A supply did all the colors show up.

Just letting everyone know, it does indeed look like a power issue. We connected the 6V battery pack (the photon was being powered by USB) and it immediately had all colors. Unfortunately, even after soldering the wires, the 5V 2A power cord for the display doesn’t seem to be doing anything…

Thanks for all your input on this everyone!


@blaisezfaire, can you post a picture of your setup again?