"404 Error. Please try again." upon compile


#1

Trying to verify code for the first time for the Photon, and just building the LED app to confirm buildchain.

Tried first on Windows Chrome and Firefox, both return the error: “404 Error. Please try again later. If the issue persists, please report to hello@particle.io

I’ve logged out, logged in again, cleared cache with the “Clear Cache” button, logged out and in again, etc.

Moved over to my xubuntu machine, same problem under Chrome and Iceweasel.

Ran a sniffer, and see it resolve api.particle.io to particle-api.nodes.spark.io to an aws machine (prod-particle-elb-12376221827 on the east coast) Those resolve fine.

We exchange some data with a couple aws machines (it’s ssl’d, TLS1.2, haven’t tried decoding it), then we resolve app.getsentry, api.segment, api-iam.intercom.io, we get the client hello for TLS, we exchange some data with segment.io (gotta get that customer tracking in there even if all else fails!), intercom, getsentry, more encrypted Hellos, we exchange some certificates, an encrypted alert, then we blow-up.

Any ideas?

Then tried using the CLI under Windows 7 Pro 64, but the squirrel goes off the installation rails with:

"at Squirrel.Update.Program.main(String[] args)
(Inner Exception #0) System.IO.PathTooLongException: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.", runs out the door and gets away without finishing the install.

The Photon works just fine with Tinker on Android, I can query the pins and get expected sensor values. I can see the Photon fine and online (with Tinker firmware) on the interface, it’s reporting up and happy.

I reset and reflashed anyway. Same results.

I started off pretty impressed - but this hangup for even getting a “hello world” firmware pushed to the device has definitely put a damper on things! Any advice greatly appreciated! This has been ongoing since at least 0900 PDT.

TIA for advice!


#2

Nevermind.

Looks like we’re blocking a good chunk of AWS…

Fortunately I’m the Director of Information Security here, so I can probably see them get unblocked for my IP… :wink:

FWDeny
blocked sites
pri=4
disp=Deny
policy=Internal-Policy
protocol=https/tcp
src_ip=xxx.xxx.xxx.xxx
src_port=61573
dst_ip=52.20.110.165
dst_port=443
src_intf=somevlanoranother
dst_intf=0-External
rc=101
pckt_len=52
ttl=127
pr_info=offset 8 S 2868860641 win 32
src_user=look!myusername!


#3

I guess it’s not worth a lot, but over here in Europe https://build.particle.io does work.
There is currently a minor glitch on one of the other servers reported on http://status.particle.io/ but that should not affect Build.


I see, things have cleared up then?


#4

Thanks Scruff - we were posting simultaneously. :smile:
No, haven’t cleared up per-se, but I suspect I have an avenue of exploration or two to make them behave. I could go exempt myself in the firewall, but that would violate my own security policy of peer-review for firewall rules, and justification there-of. I could just VPN into my home network, that’s probably the way to go. I could probably ssh into one of my servers out there and use the cli… [shrug] Now that I know what cat needs boiling, there are probably ways to go about skinning it… :wink:

Thanks though! Good to know it’s a PEBKAC rather than a Particle issue.


#5

So can we consider this back in order

Glad to know someone who knows how to work around obstacles :sunglasses:


#6

Oh, totally mea culpa. Down side to the cloud stuff - when it breaks [for you], it’s all on you to hunt it down and unbreak it. If it breaks for everyone, you’re really hosed. But then: I come from a time way back in the nineteen-hundred-and-seventies. A time when we called “cloud computing” “mainframe computing” and “cloud networks” “timeshare networking” - and thought it was all evil. :wink:

My career has lived long enough to see it all come back around again. :smile:

It’s the weekend coming up, I’ll do my development from home and hopefully will be impressed again. Seriously though: The Particle guys have done a poo-ton of work. I don’t know if everyone appreciates just how much goes into this.

And gosh is the latency low (thanks Amazon). If I plug one of the Photons in, it’s online and breathing before I can stand back up from the floor(!).


#7

Oh - haven’t resolved the issue of Squirrel/Atom path-to-long error for the CLI (although that wouldn’t help me here, it’s still an outstanding issue)


#8

How long is your user name?
I guess this is the only thing that should make the default path for that installation exceede the limit.

Have you tried the CLI installer?

Particle is still looking for willing guinea pigs that will test this and throw ever new issues back at them :wink:
Windows 7 is a bit of a bitch tho’ - I’ve got it on 8.1Pro64 and 10Pro64 without issues.


#9

I would rather have my eyes gouged out with an infected rusty melon-baller than run Windows 8. I have a virtual 10 machine with Classic Shell installed that is almost useful. :wink:

I did, however, use the installer - that’s what’s tossing the error. :smile:

Username is email address… Hmm… 21 characters. That’s a fairly reasonable email address these days. Should have seen my bangpath back before dynamic routing and dns! :wink:


Hmm, I was using ParticleDevSetup.exe rather than ParticleCLISetup.exe. Let me try that one.

… It pukes on its own shoes trying to get to aws.

Looks like the IDS got cranky with all the bad traffic and whacked the entire 52.*/11 block. I’d be willing to bet that probably 75% of AWS is bought and paid for by bad-actors. :wink: That said - I think a /11 block is a bit overkill. I tried opening up 52.204, but there were additional address ranges that Particle wanted. .200, .201,.20,.6… I don’t think trying to just allow what is needed is going to get the job done here. It’s close enough to quitting time I’m about done caring for the moment. Probably go with the VPN option instead…


#11

Ok - back in order. :smile:

It took a couple hours, but I was able to get Temperature, Humidity, air quality, and scaled FSR value to publish to the cloud, and then print to a web page. I don’t have any HTML5 experience at all; push notification stuff, eventSources, etc. (I’m old…) experience, so that by itself was the biggest challenge.

That all said - it was pretty straight forward. If an old programmer can build a working smart dog-water-bowl and environment monitor from scratch in two hours, including CAD and 3D print - it’s not that bad, right? :blush: