3G Electron _ Unable To Get GPS Location


#1

I’ve got my SIM card registered and got the 3G Electron loaded with the “AssetTracking” program.

When I monitor my serial port I get these message. See screenshot below.

image

According to the GPS NMEA manual on GNGLL protocol, the character preceeding the “GNGLL” was suppose to be my latitude and longitude.

image

I thought my GPS signal was weak so I hooked up an antenna with an SMA-to-UFL cable.

With the antenna, still no luck. What could I be doing wrong here?

Thanks.


#2

This might be a bit out there, but do you know if you have some of the NMEA messages disabled on your GPS? If it is a uBlox, downloading an using the uBlox Command center (https://www.u-blox.com/en/product/u-center) for additional debugging would allow you to determine if the issue is with the GPS.


#3

The common suggestion is to use AssetTrackerRK instead and try again.

Also make sure to first try placing the antenna outside with clear view of the sky in multiple directions and allow for 15 minutes of acquiring location data. After a cold boot the GPS module needs a fair amount of data before it can calculate a valid position.


#4

I was in the same situation and had some massive pain points getting mine to do the initial fix.
I was using the Adafruit ultimate GPS and did the following:

  • Try without the USB plugged in and just running of battery power, or plug in to a battery bank.
  • Make sure you had a cap connected to you power rail, even if your gps board comes with one.
  • Like @ScruffR said, let it see a clear sky to get the initial fix, this can take up to ~30 min some times.

#5

I was powered for well well over 45 minutes during my test.
I will give her a whirl with the AssetTrackerRK program tonight again.
It was pretty cloudy yesterday evening here in Calgary, Alberta, Canada. Weather was turning upside down here up north here. I hope I get a clear evening tonight for the test.
Thanks again for the response and suggestions.


#6

Clouds shouldn’t make a difference - it’s tall buildings that create most problems.


#7

I agree with @ScruffR. Also, satellite position relative to a given location changes all the time so line-of-site may be affected day-to-day.


#8

Cloudy day here in Cagary but it worked.
Latched on in 55 seconds to GPS satellite.
Thanks everyone!