2 Photons with the same connection problem

I currently have 2 unusable Photons. They display the same symptoms.

  1. I plug the USB in (direct from my iMac); initial white light
  2. blinks green for a second then changes to breathing cyan
  3. after 10-12 seconds changes to slow blinking green
  4. after another 10-12 seconds it changes back to breathing cyan

The whole cycle — start of cyan/end of green is about 25 seconds over and over.

I may have caused this problem. I was moving programming from my iMac to a Mac laptop. Without noticing I think I had Particle Dev accessing the same Photon (screen had gone to sleep on the laptop). Only a guess.

Unlike the Core there’s no factory reset. If I hold the reset down to the blue blink I can use Coolterm to redo the wifi like so:
SSID: abc123
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3
Password: abc123
Thanks! Wait while I save those credentials…

Awesome. Now we’ll connect!

If you see a pulsing cyan light, your device
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit https://www.particle.io/support to debug.

Particle <3 you!

The “t:1913” is from Serial.println() in the program that is still running on the Photon.

I tried the steps under your support ref. Especially the bit about resetting the public key but without success. I couldn’t install dfu-util — endless missing stuff.


It sounds like whatever app you’ve flashed to the photon is blocking the main application loop for longer than 10 seconds, causing the cloud connection to be dropped.

You can either start in safe mode, or flash tinker to the device to verify the system is operating normally.

I had already tried the safe mode gambit. When I release the reset button it
rapidly blinks yellow(?) forever. Or until I unplug it. And when I replug it in the same fugue (cyan/green) state returns. When I try to access the Photon from the iPhone Particle app it just lists the device as Offline. This applies to 2 of my 5 Photons. I sent this before (Mar 10) but got no reply.

Sorry for the delay - I’ve been on vacation for 2 weeks.

If you check the docs for safe mode, you’ll see that it should first start blinking magenta. That’s when you release the reset button to start the device in safe mode. The alternative is to run

particle flash --usb tinker

With either safe mode or tinker running on the device will allow you to see that the device is able to maintain a connection to the cloud, free from any application behavior that may be contributing to the issue.