Xenon Stuck in a Loop

Hi,

My Xenon is stuck in the following loop for the past couple of days, seemed to be working fine before that. I tried to put it in DFU mode and flash software but no luck. Any suggestions?

com-crop

Thanks!

Can you get it into safe mode?

https://docs.particle.io/tutorials/device-os/led/xenon/#safe-mode

If you can, then use WebIDE to flash something simple (I use a basic blink app) with Particle.process() in the loop(). Then if it starts okay and connects to cloud, then refresh your app.

This looks like a keys issue.
Try putting your device in DFU Mode and run

particle keys doctor <yourXenonsDeviceID>
particle keys server
2 Likes

mmmm DFU mode seems to be the issue - isn’t there some kind of ‘factory reset’ ?

I don’t think that statements actually indicates an issue DFU Mode in itself.

I rather understood it as “DFU + update didn’t solve the issue” - which it wouldn’t if it was a keys issue.

Just like x + y = -z doesn’t allow any assertion about the sign of any of the variables in question.

Hey @ScruffR tried updating the keys.But didnt help.

I also ran particle doctor, hoping i could upgrade everything but received the following error.

image

What versino CLI are you running?
What device OS version have you got installed?
What was the output of the two commands I suggested?

I realized i accidentally used the device ID of my Argon instead of my Xenon :grin:

I used the device ID of the correct Xenon today, ran particle update… And… Seems to be working now :slight_smile:

2 Likes