Xenon Power Up Problem

I have a Xenon which is connected to a computer via a FTDI cable. (TTL - RS232 - 3.3V). The cable is connected to GND, TX and RX on the Xenon. Its VCC wire is not connected to the Xenon or anything else.

Sometimes, if I recycle power the Xenon, the tiny led flashes on it once but the Xenon never powers up. In this case, the only way for the Xenon to start is to unplug the FTDI cable from the computer then power the Xenon.

I appreciate the commuintiy’s input into what may be causing this?

@Jimmie how are you powering the Xenon?

Hi @peekay123,

I am powering it by a 12V to 5V converter via its VUSB. The part is:

CUI PDM2-S12-S5

Both power sides have electrolytic capacitors per the cut sheet.

@Jimmie, I noticed on the spec sheet for that dc-to-dc converter that the minimum output current is 40ma. Also:

  1. Output load requirement
    To ensure this module can operate efficiently and reliably, the minimum output load may not be less than 10% of the full load during
    operation. If the actual output power is low, connect a resistor at the output end in parallel to increase the load.

Since the Xenon takes so little power, I wonder if this isn’t the real cause of the problem you are seeing.

1 Like

Thank you very much @peekay123.

What size resistor do you recommend?

Why does this only happen with the FTDI cable though?

Also the same power unit is powering a 5V sensor which consumes a minimum of 100 mA.

Thanks again.

@Jimmie, a 150 ohm, 1/4 or 1/2 watt resistor will consume 33mA or so. Along with the Xenon’s 18 mA or so, that should work.

I am not sure why the FTDI is seemingly causing the issue. Be sure the FTDI GND is connected to the Xenon/power GND.

Thank you @peekay123.

Yes, definitely, all devices are sharing the same GND.

Experienced a similar problem on several occasions.

My xenon is powered by LiPo battery which came with an ELECTRON. I am also using a FTDI cable 3.3v to grab serial data. I have experienced powering down the Xenon and then not being able to power it back up while it is in the breadboard connected to the FTDI. I remove it from the breadboard and leave it sit and it powers back up. Connections are
Power-LiPo
GND-GND
TX-RX
RX-TX

Hello Jackpot,

Per my earlier post, I have experienced the same thing. I contacted FTDI technical support who recommended another cable model. Same problem! While they have responded to my emails, FTDI’s help was useless.

I have solved this problem (but I am not an electronics engineer, so have no idea why this worked!). I am basically connecting the FTDI TX wire to the Drain on a P-MOSFET, and then connect its Source to the Xenon. The Gate is not connected.

Hope it helps …

@Jimmie Thanks for the reply. Crazy fix but glad it worked for you. I will try it out and Thank you