Xenon MD to 3v.. ooops

So… I was being dumb and connecting wires while the Xenon was alive (I know I know) and I accidently connected MD to 3v, and now it’s stuck in listening mode.

I can still flash to it via serial, but… yeah.

Did I bork it, or am I missing something simple (please be the later :P)

@screamingcities, connecting MD to 3.3v should not do anything, let alone cause the Xenon to be stuck in listening mode. Did you connect it to Vusb by any chance?

Also, the Xenon will be in listening mode if you haven’t set it up yet. Have you done that?

yeah it was completely setup and running. I had code flashed to it to control a DHT sensor, and it wasn’t reading so I was messing with the wiring. And yeah… it might have been USB. I was bouncing the DHT wiring between v3 and vUSB.

It was one of those WTF IS THIS NOT WORKING should have walked away and taken a breath or two moments… :frowning:

@screamingcities, the biggest thing to remember is that NONE of the GPIO pins on the mesh devices are 5v tolerant. Personally, I want to get rid of 5v stuff altogether. Much of the low power world runs at 1.65v or lower!

So it’s borked probably?

Can you put it in DFU mode? Have you tried redoing the setup?

I can put it in DFU mode… I tried setup, but wouldn’t connect through the app.

I can flash with serial I flashed a code I saw you recommended on another thread that causes the LED to go blue… And it took, but still listening mode. :-/

The MODE GPIO pin may be “stuck”. @rickkas7, any thouhts?

Did you try cli setup? particle mesh add "e00..." "other_device" -vv. You have to have them both plugged in to the computer for it to work but other_device doesn’t need to be in listening mode. If that says it’s already connected then try to unclaim it first.


I’d think with a dead MD pin you’d rather cycle through the Safe Mode, DFU Mode, Factory Reset colours after a reset/power-up.
If the device can get past that I’d suspect the DCT setup flag was reset.

1 Like

That worked!

Thank you sooo much!

1 Like