Wherefore art thou Application.h?

Trying to do a local compile including the Adafruit_RGBLCD library, but I can’t get the code to compile -

bash-3.2$ particle compile photon dryerv2.ino

Compiling code for photon

Including:
dryerv2.ino
attempting to compile firmware
pushing file: dryerv2.ino
Errors
dryerv2.cpp:2:87: fatal error: ~/Documents/Particle/Adafruit_RGBLCDShield/firmware/Adafruit_RGBLCDShield.h: No such file or directory
#include “application.h”
^
compilation terminated.
make[1]: *** […/build/target/user/platform-6dryerv2.o] Error 1
make: *** [user] Error 2

Compile failed - compile failed
bash-3.2$

I’ve tried moving the RGBLCDSheild.h file, tried giving it the full path both in and out of the project folder (you can see the results of having it outside the project folder). So, what am I doing wrong? Is the error message telling me it can’t find Application.h when it finds Adafruit_RGBLCDShield.h or is it telling me that it can’t find “application.h” (the first include) once it has frount Adafruit_RGBLCDShield.h?

Time for some Bowmore (bourbon cask matured, @christine :wink: )then bed. I’ve spent enough time this weekend not working on stuff I should have been working on over the weekend :frowning:

Thanks,
JR

1 Like

Try placing them in 1 directory and it should work well.

I just saw that Kenneth has already said what I just wrote here
Experiencing various issues

1 Like