What port does the Argon use to connect to the Particle Cloud?

I have port 5683 opened which allows my Photons to connect, but I am having issues getting my Argon to connect to my WiFi.

1 Like

The Argon uses UDP port 5684.
The Photon/P1/Core use TCP port 5683.

(Answer edited, as the original answer was wrong.)


The port wouldn’t play a role in your Argon not being able to connect to your WiFi but only to connect to the cloud.
If you have issues with your Argon not connecting to your WiFi you may run into the same issue I experience due to my DHCP server insisting in providing an IPv6 address to the Argon (since it would be capable of that) but the outbound connection isn’t.
My current workaround is to add a router that is either incapable of IPv6 or allows to fully deactivate IPv6 and use that routers DHCP.


Thank you for the information @ScruffR, it seems that I did not explain my problem correctly. I am in fact connecting to my WiFi but am unable to establish a connection to the Particle cloud. My Argon is stuck rapidly blinking cyan. I am in the process of opening port 5683 UDP as per @rickkas7 suggestion.

Status.particle.io shows a system outage right now. I have 12 customers who went down all at once.

The outage should now be resolved per status.particle.io

1 Like

You saved my weekend!!! Thank you ScruffR

1 Like

Continuing the discussion from Particle Mesh Known Issues and Fixes:

I was suffering from this issue number 4 until I fixed it by deactivating ipv6 on my router.
Wouldn’t it be cool to mention this suggestion from @ScruffR under that thread as a potential workaround/fix?

1 Like

Thank you for the suggestion! @rickkas7 is helping to manage our Particle Mesh Known Issues and Fixes – we’re very close to releasing a standard fix that should resolve this issue, but if you identify other “workarounds” that ought to be included there, let myself or Rick know.

Thanks for the help!

1 Like

My Argon’s are still having connectivity issues on my work network. They are currently running rc27 and are able to connect to a hotspot without issue. My work network has port 5683 open over UDP and TCP. I have tried disabling ipv6 routing, and I have tried limiting the number of DNS servers to two. Each Argon will rapidly flash cyan for ten seconds before blinking red once, then repeating. Is there anything else that I need to modify in my network? My Photons are able to connect successfully; do the mesh devices connect through a different IP that could be potentially blocked?

You can try adding SerialLogHanldler traceLog(LOG_LEVEL_ALL); and see if you get any helpful output on USB Serial.

Thanks @ScruffR, I ran the suggested code and recorded the following error:

0000005771 [hal] TRACE: Connecting to "SSID"
0000007671 [ncp.at] TRACE: < WIFI CONNECTED
0000008621 [ncp.at] TRACE: < OK
0000008621 [hal] TRACE: NCP connection state changed: 2
0000008622 [net.esp32ncp] TRACE: NCP event 2
0000008622 [net.esp32ncp] TRACE: State changed event: 2
0000008623 [net.ifapi] INFO: Netif wl3 link UP
0000014321 [hal] INFO: DNS server list changed
0000014322 [net.ifapi] TRACE: Netif wl3 ipv4 configuration changed
0000014323 [system.nm] TRACE: br_enabled=1
0000014324 [system.nm] INFO: State changed: IFACE_LINK_UP -> IP_CONFIGURED
0000014326 [system.nm] INFO: Checking gateway status with the device cloud
0000014327 [system] INFO: Retrieved entry from file queue, size 33
0000014327 [system] INFO: Command 2 size 29 skipped because it is a duplicate
0000014328 [system] INFO: Cloud: connecting
0000014330 [system] INFO: Read Server Address = type:1,domain:$id.udp-mesh.particle.io
0000014330 [system] ERROR: Failed to load session data from persistent storage
0000014331 [system] INFO: Discarding session data
0000014332 [system] TRACE: Resolving e00aaaaaaaaaaaaaaaaaaaaa.udp-mesh.particle.io#5684
0000015275 [system] TRACE: Address type: 3
0000015276 [system] TRACE: Cloud socket=0, family=2, type=2, protocol=17
0000015276 [system] INFO: Cloud socket=0, connecting to
0000015277 [system] TRACE: Cloud socket=0, connected to
0000015277 [system] TRACE: Updating cloud keepalive for AF_INET: 30000 -> 30000
0000015278 [system] TRACE: Applying new keepalive interval now
0000015278 [system] INFO: Cloud socket connected
0000015279 [system] INFO: Starting handshake: presense_announce=0
0000015279 [comm.protocol.handshake] INFO: Establish secure connection
0000015663 [ncp.at] TRACE: > AT+MVER
0000015675 [ncp.at] TRACE: < 5
0000015676 [ncp.at] TRACE: < OK
0000015678 [comm.dtls] INFO: (CMPL,RENEG,NO_SESS,ERR) restoreStatus=2
0000024681 [comm.dtls] ERROR: handshake failed -6800
0000024682 [comm.protocol.handshake] ERROR: handshake failed with code 17
0000024682 [system] WARN: Cloud handshake failed, code=17
0000024933 [system] INFO: Cloud: disconnecting
0000024933 [system] INFO: Cloud: disconnected

I can’t find any definitive solutions online to Cloud handshake failed, code=17, and like I said above it is able to connect to a hotspot without problems so I don’t believe its an issue with device keys. Am I correct to assume that the above log shows the Argon trying to connect over port 5684, instead of the documented 5683?

1 Like

I opened port 5684 over UDP and the Argon was able to connect.


Hey Dybm,

Glad to hear you got it resolved! Thanks for following up!

Yup, the Photon uses CoAP over TCP on 5683 but the Argon uses DTLS UDP which goes via 5684.