Webhooks to Firebase not getting Response

Hello,

I created a little test app for the Internet Button a couple weeks ago which worked perfectly at the time. It publishes an event firebase-send-data to the Particle Cloud which sends a request to Firebase.

I tried to test it today and it is no longer working.

Checking on my dashboard, the events are being received from my device, but they just stop there.

Any ideas? =\

Have you checked the state of your webhook - e.g. via the brand new dashboard UI
Read about it here Introducing Integrations
or directly go to https://dashboard.particle.io/user/integrations

What specifically do you mean by “the state”? I already checked the dashboard and the webhook is there and hasn’t changed since it last worked properly.

e.g.

  • checked if the target endpoint still exists
  • checked if the triggering device (if not set to any device) is actually the one you use to trigger

If above are OK but still doesn’t work, try recreating the webhook.
There are some reasons that might cause a webhook to be muted - but unfortunately that doesn’t seem to be shown in the integrations dashboard yet (I thought it was there :blush:)

Hi, i’m new here, i’ve been testing with webhooks and firebase, but i can’t event push any data. I always got this error:

{ “error” : “Invalid data; couldn’t parse JSON object, array, or value. Perhaps you’re using invalid characters in your key names.” }

this is my code:

unsigned int nextTime = 0; 

void setup() {}

void loop() {
    if (nextTime > millis()) {
        return;
    }

    Particle.publish("Temp","{\"value\": 25, \"timestamp\": \"24/04/2106 2:28: PM\"}");
    nextTime = millis() + 30000;
}

I was able to push data via the webhook adding Json in the additional data field, but not by the parameters in the publish() function. Here is my webhook configuration:

And this is the log

Could you help me? Thanks in advance.

@adrianmb, the “FULL URL” field contains “Temp.json” as part of the path. Is this the correct URL?

Thanks for your response, yes it is correct, it is the node where i want to store new data, i made another webhook that send aditional data in JSON to the same URL and it POST it successfully.

But when i try to send it via publish() data parameter i’m always having the same error.

Here is my Firebase DB structure

In MAC terminal i was able to successfully add data with CURL

curl -X POST -d '{ "value": 23, "timestamp": "22/04/2106 1:47:15 AM" }' 'https://app.firebaseio.com/Temp.json'

I’m not sure how you are defining your json field with passed variables. Here is an example:

{
  "q": "{{mycity}}",
  "mode": "json",
  "units": "{{units}}",
  "cnt": 7,
  "appid": "{{apikey}}"
}

The items in double curly brackets are variables I pass in the publish. In the above example, the string I use for “mycity” is: "\"mycity\":\"Ottawa,ON\"".

Thanks for your help, that solve my problem, i haven’t set the Json template properly to collect the data from Data parameter of publish().

I post my finally working setup for further reference

    unsigned int nextTime = 0; 


void setup() {

}

void loop() {
    if (nextTime > millis()) {
        return;
    }

    Particle.publish("T","{\"tempValue\": 25, \"tempTimestamp\": \"24/04/2106 2:28: PM\"}");

    nextTime = millis() + 30000;

}

1 Like