Webhook (https) issue with Azure OAUTH2/token endpoint

I’m facing an issue when i’m sending a HTTPS postrequest agains an Azure cloud server.
The post response is like: ( i sensored some fields here)


here’s the hook:

    "eventName": "webhook",
    "url": "https://host.com/oauth2/token",
    "requestType": "POST",
	"rejectUnauthorized": "false",
    "headers": {
    	"Host": "host.com",
    	"Content-Type": "application/json; charset=utf-8"
    	"grant_type": "client_credentials",
    	"client_id": "[client_id]",
    	"client_secret": "[client_secret",
    	"scope": "Scope"
    "mydevices": "true" 

When i change the enpoint to http:// i can se some response from azure so i suspect some kind of SSL issue with the invalid_client behavior.

The post request is tested with fiddler as content-type :x-www-form-urlencoded and it works correctly.

Do you know what the problem may be ?

I got it working!

The json: init was wrong. worked by changing json: to form:

It also worked by taking without the rejectUnautorized: false option when data structure was of type form: