V0.7.0 Serial fails to transmit

I’m in the process of upgrading our System Firmware to the latest (or at least a newer) version.
Starting from 0.5.3, I’ve ported our app to 0.6.4 and updated our tests.
Now I’m attempting to port us to 0.7.0. Tests are being run on an electron.

However it looks like 0.7.0 breaks USB Serial on Linux (Raspbian/Debian 9 and Ubuntu 18.04).
The serial port is registered with the system (everything looks good in dmesg, detected as a ttyACM device) however I never get an TX/RX data on the serial port.

Normally we build the System Firmware ourselves, but I’ve confirmed this problem also exists with the 0.7.0 binaries taken from GitHub releases (for 0.7.0).
I’ve created a sample app that I can use to repro this issue on a Raspberry Pi, and my development system.

#include <application.h>

unsigned long timer;

void setup()
  timer = millis();

void loop()
  if ((millis() - timer) > 1000)
    Serial.printf("TIME: %x\r\n", millis());
    timer = millis();

Is this a known problem with 0.7.0? What steps can I take to further explore this issue?

Quick Update: Swapped version to 1.0.1. Rebuilt my test-application against that and still get nothing on the USBserial port.

I once had a similar problem where the host system’s RTS/DTR flags were set in a way that prevented the device from sending.

Can you try particle serial monitor --follow?

I’ve checked with screen and particle serial monitor --follow.
Both can open the port, but neither reads any data.

I’ve tried both AUTOMATIC and SEMI-AUTOMATIC modes and the behavior is the same.
The electron simply never ships data to the Serial Port in a way the host can receive.