Using different varieties of GNU-GCC compilers to compile firmware locally


I’m trying to compile a firmware locally. I have a makefile and I’m following the process of compiling source code with a makefile, mentioned in the build docs
This makes file has references to an ARM GNU tool that has files like arm-eabi-…
While it seems that the particle firmware files on github use an ARM GNU tool that has files like arm-none-eabi-…

I tried to compile in the firmware/main directory but it didn’t compile, and I got this: *** No rule to make target dbg/bsp.o', needed bydbg/dpp-qk.elf’.

These two directories/files are related to the makefile I’m compiling. I guess it didn’t compile because of this difference in the versions of the ARM GNU compiler.

I tried to both of them use the same compiler in the two different ways, meaning Particle and my project make file both use either the first option compiler tool or the second one. However, I got errors in both cases.

One other thing I tried is I built my makefile, but with Eclipse CDT, and OTA flashed it to the Particle photon using the command line.

I still don’t know if the code actually runs or not, and I’m looking for a fast way to tell if my procedure was successful. Also, is there a way to build my makefile using the Particle build convention. I mean how I tackle this different versions of GNU-GCC compiler issue?

Best Regards,