Updating DeviceOS from 2.0.1 to 3.0.0 OTA fails on almost all devices


I am trying to update a sub-set of our B523 fleet to DeviceOS 3.0.0 to increase stability and use resumable downloads of OTA bins. However, what we see is that almost all devices start the OTA updating process, goes offline and then after some time, fails. it retries a couple of times after which we see that the units become somewhat “bricked” - pressing RESET does not affect the device state in any way. It does not go online, it does not run application firmware or anything. It simply flashes white and shuts off the LED again.

It is not a problem to do a wired update during production, but we still have a lot of units out in the wild and we cannot risk bricking devices that are +14.000 km away. I’ve tried testing a bin-file without application firmware, but only compiled against 3.0.0 to minimize the bin size, but even this fails somehow.

Anyone else having problems updating from 2.0.1 to 3.0.0?

Hi @claursen - we would like to prioritize this request, would you mind opening a support ticket?

Are you able to run particle serial inspect via the CLI on any of the affected devices?

Thank you for the reply @marekparticle - I’ll be testing some more Tomorrow at the office, after which I will reach out!

1 Like

Also on B523, we are staying with 2.0.1 for now.

1 Like

I’ve tried checking for OTAs pending using System.updatesPending() and giving it a couple of minutes to update, however, I still see that if I change the DeviceOS from 2.0.1 to DeviceOS 3.0.0 it fails repeatedly. Updating firmware only and keeping DeviceOS locked to 2.0.1 works fine.

I believe we will stay on 2.0.1 until whatever bug/issue with updating DeviceOS between the two versions has been solved.

For what it is worth, it seems like the DeviceOS update fails after the system resets somehow. I don’t know if it fails some kind of checksum check or fails to boot into safe-mode.