Unresponsive Photons

Is this company just smoke an mirrors? Has anyone ever heard from anyone in support or sales from this company? I have 4 new Photons and 3 of the 4 are defective. I haven’t even tried opening the 4th. One doesn’t light up, one has a glob of solder on the antenna connection and the pad is not soldered down and the third is stuck in a state where it cannot be factory reset, flashed, etc.

I first emailed them on 12/14/2015 and got no response. On 12/17/2015 I emailed them again and also posted on their Facebook page.

I don’t know what to do. I am about at the point of reporting it as fraud to my CC company so I can at least have a chance of getting my $60.00 back on the 3 defective units.

@corey will be able to help :smile:

They have a lot of support emails so do give them some time to respond :wink:

1 Like

Could you take some pictures of the defective units?

Hmm, interesting. Have you tried searching the docs for “factory”, because when I do that, it gives me the following:

Factory reset is not available on the Photon\

That might have something to do with why that doesn’t work.

That said, what does it do, any particular light patterns? Does it connect to the internet? Does it connect to the cloud? have you claimed it? Any and all information that goes further than “it’s broken” would be useful in trying to find a way to help you out.

Regarding the mails; not sure what happened there, but I’ll go with @kennethlimcp in saying that you’re probably not the only one mailing them, and that they’ve got their hand full. They most certainly do answer them. Seeing as they’re not pinged again, I’m sure you’ll get a response soon.

So here is board #1. This board only shows the D7 LED lit up. The board is not reachable, cannot be reset. I also noticed the center of the board gets warm likely from the WiFi component.

The second board while it seems to power fine has a defective antennae connector. The second picture of board 2 shows it close up. The connector’s pad is not soldered down and the solder ended up on the connector itself. I find it shocking this was not seen in QA.

The third board starts by flashing blue for about 6 seconds and then turns to a blinking green. I haven’t been able to communicate with this board. I haven’t been able to factory reset it. It just keep starting and running the program that was flashed onto the board. Here is a picture of the Green state but I added a link to a short video.


Video of Board 3 Failing

I am very mad at you for calling Particle “smoke an mirrors”. They are one of my favorite companies. I like Particle so much Particle.io is my browser’s home page. The people at Particle are only human and they can’t just focus on you! Give them some time to respond.

2 Likes

Hi @JerseyTechGuy

Your first board appears to be in the “no firmware” state. It can be rescued with a JTAG programmer but you otherwise might have to get a replacement.

Your second board certainly has some problems on that connector!

Your third board is having WiFi trouble and seems to be connected fine and then fails for some reason. There are lots of ways this can happen but a common one is that your router has both 2.4GHz and 5GHz bands and tries to move all traffic to the upper band (Apple routers are particularly bad in this regard). If you have a multi-band router, try renaming the SSID of the 5 GHz band so that it cannot try to force your board to the higher band. You should up with something like “mySSID” and “mySSID5GHZ” for the two bands.

Note that there is no “factory reset” for Photons, so don’t try it. Instead there is safe mode which works a lot better.

I notice that in all the photos you are using the same USB cable. This is another common source of problems since lots of USB cables either can’t handle the current or don’t have the data wires hooked up, so if you think that could be your problem, you might want to try a different cable.

A lot of the Particle Devel team is focused on getting electron out the door but the customer service guys should helping out.

Are you Joking @Greg123. There is no company producing the amount of product that Particle does that takes 5+ days to respond to a sales/support request. We’re not talking about a case of me being some noob who doesn’t know how to hook up a board. We are talking about 3 out of 4 boards being defective. That $60.00 worth of paper-weights. You don’t know me nor do you know what I do. For all you know I could be evaluating their product and company for a possible project that could be a purchase of Hundreds of Photon boards (oh wait… that’s actually what I was doing).

So you’ve been able to program the third board, seeing as you mention that it runs the code that’s one there. Could you try getting into safe mode, since it looks like the user application is blocking the cloud connecting, which is being indicated with breathing green. Safe mode should not run the user app, connect to the cloud, and thus let you reflash it OTA.

I am very sad that you have had such a bad experience with your Particle boards.

Thank for the info @bko. I did try the JTAG reset and flash but this only proved the board is shot and needs replacement.

As for the third board, My bands on the router are very uniquely named differently thus there would be no chance of this issue.

The USB in the pictures was simply for photographic purposes and was only connected to a 5V 1.5A Wallwort. On my programming bench I have another cable I use for several boards. These cables I use are High Speed, Shielded, all wires through USB3 capable.

Who did you email about your problems with your issues with the Photons.

Hey @Moors7, good call on the safe mode. I couldn’t get it into safe mode originally and I guess now that I tried again I realized I might have missed the “When the RGB LED blinks pink, release the MODE button” step so it would never flash pink just yellow.

It looks like the code was hung because of a loop that checks the SD card on my other connected board and the SD was failing. The loop had a while (1); in it. When I removed that it solved the problem. So now I am only down to 2 bad boards.

Thanks again @Moors7.

1 Like

This thread will be locked and officially followed up by Particle HQ.

Hi @JerseyTechGuy - no smoke and mirrors, just human beings who answer emails as quickly as they can. Unfortunately the timing is not great because the team just dispersed for the holidays, and while we will be keeping our eye on the inbox over the holidays, we are mostly out of the office.

The support team is aware of this thread and will hopefully get back to you soon. In the meantime, the community here is a great place to get help 24/7 and generally faster than our tech support is - glad to see @Moors7 was already able to help you out a bit.

3 Likes

Also - changing the title of this thread so that it’s in compliance with our community guidelines.

Thanks for jumping in @zach! It looks like we did get the first email on Monday, but it took a little while to get moved into tech support. This has been a crazy week with holiday shipping and everything, and like Zach said usually we strive to respond in less than 24 hours, so I’m sorry that wasn’t the case this time.

We stand by our product and will of course replace units that aren’t functioning as a result of manufacturing defect. I’m looking into your ticket now and will try to respond shortly.

edit: replied, you should receive an email shortly.

Thanks!
David

2 Likes

opening this back up! :slight_smile:

Hey @JerseyTechGuy – I’m on the manufacturing team here at Particle, and agree that the unit with the glob of solder on it should not have left the factory. I’m sure Dave is already working on replacements for you, but wanted to let you know that I’m following up with our contract manufacturer to report the issue.

I assume that the barcodes that you included in each image are for the corresponding device, so the device with the glob of solder had the ID, “PH-150818-7PDX-0”, correct? This will help me identify which of our contract manufacturing partners the device came from.

Yes @will , I matched the boxes to the product for each photo for easy identification. Yes, I believe Dave is on top of replacing them. Thanks for your help.