Unable to transfer wifi cradentials with Tinker

Can someone please provide links to firmware (.bin files) and DFU-UTIL commands to completely reflash a core. I have dfu-util running on a windows 7 computer and core in DFU mode. I can’t get this core to connect to wifi. I have others on the same network with no problem. Thank you.


All you need is both the CC3000 and tinker binary file.

The command will be:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D XXXXXXXX.bin

Flash the CC3000 patch first and you will see it blink magenta and eventually revert to blinking yellow.

Once that is done, flash the tinker firmware and the core should eventually enter blinking blue Listening mode :wink:

Flashed cc3000 and tinker firmware fine but still can’t get past flashing blue. Any ideas?

How are you sending wifi credentials? You might want to try sending it via USB instead and see how it goes :wink:

Sending credentials with tinker iPhone app. What could be different about this piticular core?

1 Like

This is good advice for dfu-util v0.7 but if you’re running dfu-util v0.5 (still the version supplied in the Ubuntu repositories) then you need to leave off the ":leave" and perhaps also use the -e option.

It should work the same but let’s try using USB to send wifi credentials and see if it’s able to connect to the network first? :wink:

Setting wifi credentials with USB worked! After that I cleared credentials then iphone app worked to transfer credentials. Why do you think it was important to set credentials with USB first?

There’s no direct co-relation but I’m glad it worked :smiley: