Unable to get older Photon to run any firmware

This may be more than one problem but I am trying to flash a couple older photons that were running an old OS (0.5.0-ish). I’m able to get them online and can see them come online in the console events log but the firmware won’t actually run. I’ve tried safe mode, DFU, flashing several times from the web IDE and from the CLI, nothing seems to work. The flash always says successful and I see the device come back online but even with a very simple one line of code to publish a test message, still nothing. Tinker will flash but doesn’t respond to tinkering which would tell me the firmware isn’t running at all. The web IDE and console show Unknown OS as well.

Am I missing something simple? Can somebody point me in the right direction to get these working? One last kicker, the photons are plugged in 1000 miles away. I can remote desktop the PC they’re connected to so I can work on them via USB but I just started getting a CLI error (LIBUSB_NOT_SUPPORTED) when I try any USB commands to the board. I’ve tried reinstalling the CLI as well as the standalone windows drivers with no luck.

Can you try using the mode command to change the baud rate to 14400?

This will put the photon into dfu mode and works pre USB commands.

If you can get the photon into DFU mode on the remote machine, try running the following to update the firmware on the photon:

particle update

You guys rock! The 14400 baud worked perfectly and she’s back up and running. Thanks for the quick help.

3 Likes