Unable to add new public key

My photon suddenly started blinking cyan with red bursts. I tried the keys doctor through my windows system but right around the last step, it is not able to add the new key.
At the last step, my photon is leaving the dfu mode before the keys doctor could finish and thus the process is failing.

Have you tried logging out and back in

particle logout
particle login

Are you running the command from a directory where it has write access (i.e. not from C:\Windows\System or such).

I have tried that. Didn’t work. And I am accessing from my user directory.
There is one more problem where I am not able to update my particle cli

This is the result if I try to update:

But I am on version 2.1.1 and the latest is 2.8.2 I guess

You can try uninstalling CLI and freshly installing it via the latest installer.

I have already tried it. Not able to uninstall it.

Any other method to remove it and install the new version?

Not via npm but via Windows Programs and Features.

When reinstalling make sure to tick the “Remove old drivers” checkbox.

Even after reinstalling there is the same issue.

Even after changing the directory, it is not able to send the new key details to the server.

What are the permissions missing here?

@marekparticle, can you help?

Permission denied when sending to the server occurs when the device is claimed to a different account than you are logged in as. The device listed in the first screenshot is claimed to a different account than the email your community forum account is using, so that would be my guess is the problem.


The relevant CLI command is particle login. (Ah, I see ScruffR already provided that information). You can DM me the User ID you’re trying to use and I can see if it’s correct for this device.

1 Like

I checked and indeed it was claimed to another email. How do I claim it with my email id now that it is not able to communicate with the particle server?