Turn off Search hijack?


#1

Hi,
When searching for text in a long thread on community.particle.io, pressing CMD + F will not open the default browser search, but rather a feature that allows me to search the entire website. I CAN tick the box that says “Search this topic”, but it does not provide anything useful since it does not highlight all the hits in a page.

Not being able to search inside a single page is extremely frustrating. As a developer, I know that I can just right-click the search-field, choose Inspect and delete the browser DOM node with the class of “search-menu” to get the normal search back, but when looking through multiple pages looking for an answer it is extremely frustrating.

Can you please remove this “hijack” and just let us click the search-button ourselves if we want anything other than the default behaviour? It takes me more time to circumvent the feature than it’s saving time…


#2

Uhm, how about you go to the edit menu -> Find -> Find. Rather than having people change their entire forum for you? 3-clicks it should take you as cmd + f = 2 time pressing key. The 1 action more should not take you that much time…


#3

True. I’ll do that.

The reason I suggested it to be changed is that I do not think it’s it’s good practice to override browser features. The existing feature is also buggy since in 50% of the times I press CMD+F it’ll show the browser dialog vs the Forum dialog.


#4

What browser are you running?

I’m on Chrome on Windows and Ctrl+F does invoke the browser search feature and not the Discourse one (which isn’t a Particle product, but only used by them)


#5

I’m on OSX with the latest Chrome. Like I mentioned above - I only get the Discourse dialogue on 1 in 2 threads when pressing CMD + F. The solution suggested by @vibrocil works well though, so I can live with that for now.

It is odd that you’re not getting the dialogue is using Chrome though? Could you open for instance this thread and try there? For me it happens every time I use the keyboard. From the menu, I always get the browser feature. This happens on Win10/Chrome and OSX/Safari also.


#6

Yes, on that thread I get your issue too - strange :confused:


#7

It’s not a big thing, but it’s somewhat annoying. I’m sure it’s just a boolean in the config files for the forum. Oh well.


#8

On that thread if you press ctrl+F and than F again (holding control) in chrome on windows it switches to the normal search…


#9

Good find @vibrocil! Same on OSX!