Turn off automatic system updates?

I’m having trouble with some code that works fine on 0.4.9, but doesn’t seem to run on 0.5.0. I setup a new photon, and it updated to 0.5.0, and I noticed some issues. I upgraded my working version to 0.5.0 to see if I noticed the same issues, and I do.

I now want to downgrade to 0.4.9, but can’t seem to do that. If I enter dfu mode and manually flash 0.4.9, it works, but then the Photon resets and I see lots of flashing magenta, which I believe means it’s updating to 0.5.0. When I enter setup mode after that and do a serial identify, it reports 0.5.0.

I guess I’m not positive it’s updating back to 0.5.0 immediately, but the 0.4.9 flash seems to work, but then it’s back to 0.5.0.

I’d prefer to disable automatic updates, as I don’t want devices in the field to stop working if I have a firmware-related issue in my code.


If you flash tinker first before downgrading the cloud will not try to update. The update is happening because your application was compiled for 0.5.0, which puts the device in safe mode when system firmware is older. To get your device working again, the cloud flashes 0.5.0. Flashing tinker will avoid this since the tinker app was compiled against 0.4.0.

I’m interested to know what behavior has changed between the two versions. Our aim is to make system firmware backwards compatible (notwithstanding bugfixes) so any divergence from that is something we’d like to know about :smile: