Troubleshoot: Particle-CLI on windows [Q&A]


#41

http://www.microsoft.com/en-us/download/details.aspx?id=29


#42

Good idea guys, I didn't realize that was needed for the OpenSSL install, I added an issue for this here: https://github.com/spark/spark-cli/issues/67

Thanks!
David


#43

Thanks @BDub for letting me know wink

I have the post updated already. Let me know if you see more issues.


#44

OpenSSL v1.0.1h is out:
http://slproweb.com/products/Win32OpenSSL.html


#45

Do we have to? stuck_out_tongue I'll update it now smiley

You know...my dropbox files are meant for the beginners and advanced users won't bother to download =D


#46

You said "Let me know if you see more issues" wink

Why not just link to that site and say grab the latest version of Win32/64OpenSSL-1.0.1h or higher!

I also didn't know if there was a downside to installing the FULL version of LIGHT version as it pertains to the CLI. I would think LIGHT should work just fine and install less crap on your computer.


#47

I ran into a very minor issue with Zadig. When I run the .exe the default device was "CORE DFU". If I selected options --> list all devices and select libusbK and install, I got a "driver failed to install" error.

When I excluded the options --> list all devices step, the driver installed fine.

Very small point of potential frustration with a very easy workaround smile


#48

Ohh.... thats weird but anyways smiley


#49

I'm having and issue with the " Run 'npm install -g spark-cli' " command.

When I enter that into the node js command prompt it only goes " ... " and never installs?


#50

Was in Wrong Command Prompt.

Have it installed YAY!

@kennethlimcp You're awesome for making that tutorial


#51

I am trying to install it on windows 7 behind proxy wall ( i know dizzy_face ). And am getting error

login error: { [Error: connect ECONNREFUSED]
code: 'ECONNREFUSED',
errno: 'ECONNREFUSED',
syscall: 'connect' }
Error logging in Login Failed: Error: connect ECONNREFUSED

Last time i did sort it out some how, but dont remember how . Anyone remember how to overcome it? As far I remember it was edititng some file to incorporate proxy server and port in it.


#52

Hello

I followed the tutorial to install spark-cli on Windows but am still getting an error: LINK : fatal error LNK1181: cannot open input file 'kernel32.lib' [C:\Users\Emmanuel\AppData\Roaming\npm\node_modules\spark-cli\node_modules\serialport\build\serialport.vcxproj]

I tried to add kernel32.lib in the path but it does not help (C:\Program Files (x86)\Windows Kits\8.1\Lib\winv6.3\um\x64 and x86).

Any thoughts ? Thanks

Emmanuel


#53

Hi again,
I finally managed to get this to compile correctly but did the 'npm install -g spark-cli' from the 'MS SDK Windows v7.1' command prompt (and not the nodejs command prompt).
The 'MS SDK Windows v7.1' command prompt comes with MS VC 2010, which is required by node-gyp according to this link https://github.com/TooTallNate/node-gyp/wiki/Visual-Studio-2010-Setup.
Emmanuel


#54

I'm not sure if this should go in another thread @kennethlimcp, please feel free to shift it as you see fit.

I have spark CLI installed and I want to upgrade / rebrand / change to particle CLI. What is the best way?

Uninstall everything and start again?


#55

npm uninstall -g spark-cli and npm install -g particle-cli smile


#56

@kennethlimcp, Sorted, thank you very much. smile


#57

Hi all. Is there a way to run Particle-CLI from behind a corporate proxy? Thanks!


#58

Hmm @UMD it should just work as long as you can connect to the internet.


#59

@kennethlimcp the last time I tried it, it did not. Am not at work today, but will report back with the error messages tomorrow.

Does anyone know what outbound ports Particle-CLI is using? This could be an issue too…


#60

It is really just HTTPS api calls.

See this example: https://github.com/spark/particle-cli/blob/master/lib/ApiClient.js#L272