Troubleshoot: Particle-CLI on windows [Q&A]


#21

Lolololololololol. That’s always a good fix!


#22

Yeah…that didn’t work, either. My happy and sad is trending to more sad now. Perhaps I should quit while I’m ahead! (or switch to my Mac!)


#23

Ohh you mean the error on serial? It’s an issue on windows now so just wait for a fix :slight_smile:


#24

Gotcha!

I shall spend my time working to make my Spark sentient so that it will do my bidding. :smiley:


#25

You might benefit from this topic if you are on Windows: https://community.spark.io/t/installing-the-usb-driver-on-windows-serial-debugging/882


#26

Ok, so spark-cli is working on my Win8.1 pc. I want to compile an entire directory containing all the necessary .cpp and .h files. When I try and do a cloud compile of the directory it quickly spews out an error indicating there is no such file for a file that is clearly there. Am I missing something on how the CLI works? Do the files need to be separated into inc and src folders? Do I have to have a build.mk file in there?


#27

Can i check if anyone has tried to install Spark-cli on OSX (10.9)? straight after spark cloud login am getting:

Got an access token! 1234567890123456789012345678901234567890
logged in!  { '0': '1234567890123456789012345678901234567890' }
There was an error writing [object Object]:  { [Error: EACCES, permission denied '/usr/local/lib/node_modules/spark-cli/spark.config.json']
  errno: 3,
  code: 'EACCES',
  path: '/usr/local/lib/node_modules/spark-cli/spark.config.json',
  syscall: 'open' }

something (spark-cli?) doesn’t have access permission to the folder specified - anyone else seen or thoughts on how to resolve?


#28

Hi @mikepa,

There is an issue for this bug here: https://github.com/spark/spark-cli/issues/10

The cli should be storing it’s config in the user’s home directory, and not with the application. I’ll be doing a CLI day on Sunday, so a fix should come then hopefully. :smile:

Thanks,
David


#29

Hi @peekay123,

Thank you for trying the CLI - Can you send me the error output?

Thanks,
David


#30

Dave, I will PM you on this.


#31

thanks for the pointer @Dave - hadn’t thought to check Github for this type of thing.


#32

I wanted to jump in and say the requirements for installing the node-serialport module have lessened significantly. You should no longer need the node-gyp / Python / Visual Studio C++ express stuff.

Thanks!
David


#33

What was the solution to this? I’m getting the same error.


#34

What’s the issue you are facing? :slight_smile:


#35

Hi Kennith. If you click the little image of peekay123 in my post you can see the quoted message that I’m replying to. (I’m not used to this forum software either, but I like it!) I got a PM from Dave pointing out that local libraries have to be in quotes (not brackets) when importing them for compile using Spark-CLI.

I.e. #import "library.h", not #import <library.h>.

One question I still have is what about application.h? Is that available for import globally server side when I do a cloud compile, or do I need to copy all the Spark library files to my project folder too?


#36

For #include "application.h", it is available for the server side and you do not have to include it.

You only need the library files you are using :slight_smile:


#37

Just going through updating my CLI install… there are new versions for all of the programs you’ve linked to up there :wink:

Also a link to the MS V++ 2008 Redistributable would be good.


#38

For node.js? Why do we need the V++ since its no longer a prerequisite? :slight_smile:

I’ll update the links later but would be more awesome if there’s a “latest” version link.

Thanks @BDub!

Going to setup in my windows running on Parallels later :wink:


#39

The OpenSSL installation complains about it if you don’t have it on your computer…


#40

I didn’t know that…