Trouble with connecting a photon to AWS IoT using web hooks


#1

A quick description of the problem I am having. I’m trying to send data through an i2c connection, from a temperature/pressure sensor to the particle and then to AWS IoT to run queries. Everything works fine with sending the data to ‘things speak’ (software in the web hooks tutorial). I can view the sensory data on the charts with ‘things speak’ and I can see the data show up on the serial ports in the particle console terminal. When I try using the same scheme but instead using web hooks to send the data to AWS is where I run into problems. I’ve seem some previous documentation but I haven’t had success finding an API endpoint address on AWS IoT that works with the web hooks offered by particle. I have tried to connect the photon to the AWS IoT platform but I don’t think it’s possible to flash the firmware and cert that AWS requires. AWS IoT Kinesis offers a REST API that is HTTPS. Webhooks won’t accept this address.
Basically I have tried to hook my device (photon) up to AWS IoT in two ways. The first way was through AWS IoT registry. This required me to open a zip folder on my device (photon). This folder is called the ‘connection kit’ by AWS. It has certificates and a power shell command prompt for communicating with the photon. Does anyone know how to unzip the connection kit onto the photon?
The 2nd way I have tried to connect my photon to AWS IoT is through AWS Kinesis. I created a stream and and analytics project and tried connecting those to the web hook. No luck. Thanks for any advice.


#2

Nevermind, I have found the API endpoints.


#3

Thanks for letting us know!


#4

Hi there!

I have the same use case; can you kindly tell me which API endpoints you used, and which approach worked ( 1.- AWS IoT registry or 1.- AWS Kinesis)?

Thanks!


#5

Neither way worked in the end. But I worked on that project a while ago.