Trouble powering core through relay shield [Solved]

I have connected a 9 volt battery to the barrel connector on my relay shield and everything is fine for ~45 seconds then the power light on the shield goes out and the rgb led on the core dims greatly and has the red and green lit up. pressing the reset button and unplugging and re-plugging the barrel connector both result in the boot sequence and once it is about to reach breathing cyan it returns to the dim red and green. This has occurred when using tinker to control the relay as well as my own code.

I’m not sure if I’m doing something wrong.
Thanks in advance for any insight that you can offer

What happens when you power the board with a 9v-12v 1-2amp wall wart, and not a battery?

@Dave first off sorry for bumping such an old post but I am having the same issue with 2 relay shields I purchased. My power supply is 12volts DC at 500MA.

I have tried two relay shields and multiple different cores with similar results. Battery power pack delivered similar results.

Thanks for the help

Hi @Herner,

I wonder if trying a power supply that could deliver more current might help? How about something like…


I will try just that I have a spare one I found that I can try rated at over 1

1 Like

Just FYI that did work.

1 Like