Trouble flashing to the Spark Core DFU

Ok so I have been having trouble flashing to the spark core DFU. A couple days ago I was able to do it with the online spark IDE. But for some reason now, whenever I am trying to flash to the DFU I get problems. I have installed the drivers for the DFU with Zadig (with driver settings: libusbK (v3.0.7.0)). I have tried running this command in the command prompt: dfu-utill --list. It then gives me this:

Cannot open DFU device 0a5c:21d7
Found DFU: [1d50:607f] ver=0200, devnum=4, cfg=1, intf=0, alt=1, name="@SPI Flash :smile: SST25x/0x00000000/51204Kg", serial=“6D80416B5550"
Found DFU: [1d50:607f] ver=0200, devnum=4, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x08000000/20
001Ka,108*001Kg", serial=“6D80416B5550”

I just don’t understand why it says Cannot open DFU device 0a5c:21d7

I have also tried running a program in NetBeans and I have been getting this:

File downloaded successfully
Transitioning to dfuMANIFEST state
No valid DFU suffix signature
Warning: File has no DFU suffix
Error during download get_status
read from master failed
: Input/output error

RUN FAILED (exit value 1, total time: 14s)

Why is this happening? Any help would be greatly appreciated. Thank you!

A couple things to do/try:

  1. A different USB cable
  2. A different USB port (is yours a USB 3.0 by chance?)
  3. How about a screenshot of your device manager with the Spark Core device in frame?

Ok a couple things.
1: I did try a different USB cable
2: Mine is USB 3.0 i believe. is that a problem?
3: Here is a screenshot:

USB 3.0 is indeed a problem. Apparently it does not work. Can you try a 2.0 or 1.0 port?