Tinker analog read returns -3

Boron. Tinker worked fine from my phone out of the box. I then flashed Tinker app over cellular. Boron rebooted fine. Digital writes work but now all analog read requests on the app return -3. Any suggestions? Thanks!

When you look in the Tinker code you’d find out that -3 indicates you tried analogRead() on a D pin which are not analog readable.

Hence the D for digital vs. A for analog :wink:

Yes, thanks, I saw that in the code. But what I am using is the Tinker app, asking for an analog read on analog pins 0-5, and am getting -3.

Works for me tho’
Have you tried via console.particle.io/devices?
There you should find your Boron. Click on it and then find this
image
Enter the pin name and hit CALL

If you still get -3 you can reflash tinker via CLI particle flash <yourDeviceID> tinker and try again.

BTW, what version of the Particle App are you running?
What device OS is your Boron on?
I tested with the Android App v3.1.1 and device OS 2.0.0-rc.2

Thanks - the weird thing is that it worked before I flashed the current version of Tinker, but not after. Analogread gave 0
Boron v 1.4.4
Android Particle 3.6

All of that said, other programs such as demo “Function Variable” work fine.

Not sure I’ve seen this version before. I’m pretty sure 3.1.1 is the most recent version.
Are you sure you haven’t just looked at the Playstore rating - that is 3.6 :wink: