System.factoryReset() not working on Photon

I have tried to use System.factoryReset() as a last resort troubleshooting method for customers experiencing issues with their products based on the Photon.

But so far, every time I run System.factoryReset() it just performs as a normal reset, like System.reset(). Once the Photon restarts, it still had the WiFi credentials and user firmware. I get the same issue with 0.4.4rc2 and 0.4.4rc3.

Has anybody else experience this?

Factory reset doesn’t operate as normal after updating system modules, since these overwrite the factory reset area (and there is no more room in the photon to store a factory reset image.)

To clear wifi credentials, you could use WiFi.clearCredentials(), followed by System.reset().

In hindsight, factory reset should probably have been removed on the Photon since it makes less sense on that platform than on the Core, since it’s not possible to reset the system firmware. I will think through how we can make the system behave in a more consistent manner and provide an update in a future release.

1 Like

Thanks for the answer. It might be worth updating the documentation to describe the real behaviour of factory reset on a Photon.

1 Like

Definitely. Added to our backlog -

1 Like