Stuck in SAFE MODE and can't put it in DFU

Hello, I am having a problem with a photon that was previously working. It seems to be running 0.4.3. It breaths magenta but turns sometimes into solid magenta. I dont seem to be able to put it in DFU mode nor flash it OTA. If it breathing magenta it shows online in the cloud as expected.

When trying to set it in DFU mode if in solid magenta, nothing happens; if breathing magenta even if i start by pressing both buttons the behaviour is as if I am pressing only the setup one. (slow blink blue, and after a few seconds fast blue blink and wifi credentials wiped).

I tried to bypass the reset button by shorting its contact “legs” but with no reaction.

Any ideas on how to bring it back to life?

Can you place it in Safe mode (breathing magenta), go to and select the system firmware to 0.6.1.

Next up would be to flash an empty firmware to the Photon.

Hello, thank you for the quick reply.

I have tried to flash OTA empty or not empty but it would timeout. I have however managed to make it work and will share here in case someone may find it useful.

It seems that this particular photon does not have the RESET button working. I managed to put the photon DFU by holding the SETUP button before connecting the USB cable, aparently replacing the reset function.

After this I flashed tinker using particle flash --usb tinker. It started pulsing cyan. Despite this, however, OTA flash would still timeout in or cli.

Putting the device in DFU mode again and flashing both part1 and part2 of 0.6.2 appears to have made the Photon act normal again and accept OTA flashes, yeay!

particle flash --usb system-part1-0.6.2-photon.bin
particle flash --usb system-part2-0.6.2-photon.bin

Thank you

Another way to mimik a RESET button press would be to connect the RST pin to GND - that’s what that pin is for :wink:

Ahahah, now I feel silly I didn’t try that before. In this particular Photon, however, that also does not work , no reaction just like when shorting the physical RESET button.

For confirmation I also tried with my other photons and no problem with the other five I tried. I reckon this one is actually a little faulty. But well, from all things to be faulty let it be the reset : )