Strange behavior : difference between power supply and USB via pc

Hi All,
I’m a new user of spark. I made some projects with Arduino but I’m now spark addicted!! :smiley:

the issue is:
I build a simple sketch to control a led by calling URL.
The code works and if I attach the core via USB to the pc everything it’s ok.
If I use a simple USB adapter and power the core, it seems connected to internet (Slow breathing cyan led) but the program is not loaded. I tried to call the URL to light on the led but I received a timeout.

Is there any difference to use USB via PC or a simple USB adapter?

thank you for your help!
ciao
Roberto

In theory, no. It’s possible that you have a bad USB power supply, but I haven’t had any problems even out of the really cheap ones. Do you have another USB power supply that you can test with? Let’s rule that out before we dig deeper.

I confirm the strange behavior. I tried with several USB adapter, but the program works only If I connect the core to PC USB.

the “Slow breathing cyan” for the core led it means that core is correctly connected to cloud, right?
In this scenario I’m not able to flash OTA. It seems that the core is not real connected.
is there any way to debug this case?

thank you!

@noce2k, can you explain more about your program, possibly post it here? It sounds like a serial issue my be involved. :smiley:

2 Likes

Hi Peekay123, you are right about serial issue!!
it’s my fault.

if you write:

Serial.begin(9600);
while(!Serial.available());
Serial.println(“Setup routine”);

it’s very difficult that the program works without a serial :blush:

I commented the while and all works as expected :smiley:

thank you again for help.
I love this community!!

3 Likes