Stopped communication with tcp server and no response from spark web ide

Hi.

I have a spark on a remote location and have no physical access at the moment. I can see traffic going to a amazone host. I think this is where the spark cloud is hosted. But in spark web ide the spark is unreachable and from the programmed tcpclient the tcp server doesn’t get any data anymore.

see tcpdump:

09:02:04.851941 192.168.200.41.1553 > 192.168.200.1.53: 171+ A? device.spark.io. (33)
09:02:04.852278 192.168.200.1.53 > 192.168.200.41.1553: 171 1/0/0 A 54.208.229.4 (49)
09:02:04.855174 192.168.200.41.2096 > 54.208.229.4.5683: S 658136748:658136748(0) win 1460 <mss 1460> 
09:02:04.958508 54.208.229.4.5683 > 192.168.200.41.2096: S 3910887224:3910887224(0) ack 658136749 win 17922 <mss 8961> (DF)
09:02:04.961448 192.168.200.41.2096 > 54.208.229.4.5683: . ack 1 win 1460
09:02:05.064240 54.208.229.4.5683 > 192.168.200.41.2096: P 1:41(40) ack 1 win 17922 (DF)
09:02:05.067900 192.168.200.41.2096 > 54.208.229.4.5683: . ack 41 win 1460 
09:02:20.169009 54.208.229.4.5683 > 192.168.200.41.2096: . ack 1 win 17922 (DF)
09:02:20.171987 192.168.200.41.2096 > 54.208.229.4.5683: . ack 41 win 1460
09:02:35.064136 54.208.229.4.5683 > 192.168.200.41.2096: F 41:41(0) ack 1 win 17922 (DF)
09:02:35.067246 192.168.200.41.2096 > 54.208.229.4.5683: . ack 42 win 1460

How can I reset the device to be able get it in working mode. And why does spark web ide not show the core online and fails to communicate with each other?

Any one some clues?

Regards

Robert

There might be some code knocking the communication to the core offline and remote reset is not really possible… if you did not take that into consideration before performing a remote deployment…

Well, I admit I was a bit optimistic … The test setup had run without issues for multiple weeks (maybe even months) and never had this issue. I tested even with communication issues high delay, package drops etc. All worked fine. Even after total disconnect it returned in working order. All automatic.

I see from tcpdump it is communicating with device.spark.io but the web ide does not show the core to be online. So I think there is may be something more wrong. Not only my lack of recovery or even reset code in the core.

If i check with curl.

curl 'https://api.spark.io/v1/devices/55.... ?access_token=d4889... 

{
   "id": "55ff69064989495344412587",
   "name": "tcp-temp-client",
   "connected": false,
   "variables": null,
   "functions": null,
   "cc3000_patch_version": "1.28"
 }

device.spark.io does not see it but tcpdumps look like it is communication (calling home). From the dump it self I can’t tell if it is working normal. As the data looks encrypted (ssl?).

Have you tried flashing code vis OTA now?

Or you have tried and failed?

@kennethlimcp, could it be an expired token?

I don’t think so since the core doesn’t rely on access tokens but that’s a good point!!

His curl worked though…

1 Like

The token was not expired, when using curl you get some warning about that like:

"error_description": "The access token provided has expired."

So the question remains how to adjust code so communication could be reset? If communication with spark cloud environment is lost for some reason.

Maybe some thing like a small tcp listener (with simple authentication) to let it perform a reset.

But it fails now also to send data to a central server so probably the code is also not running anymore.

Well maybe someone has a possible solution or workaround build already for these situations?

Regards

Hi, Just a small update.

I could get it back by disabling it on the access point ( block wifi device ). This caused the spark core to reset and get a working connection with spark cloud and my tcpserver. Now I need to figure out why it did not talk and how I can make a routine that resets it or a deep sleep calls and hopefully triggers a wakeup for the device.

Regards

1 Like

That’s a smart move! :smiley:

Its a bit like hitting it with a stick … but did the trick :slight_smile: