Spark Dev Probs

Sorry for being so bad with computers. I got all excited for spark dev, because I’ve been unable to use my spark due to the wifi at my campus not accepting it, and I wanted to program it with USB.

Anyway, it appears to not be working. At all. The compile button doesn’t do anything, and neither do any of the other picture buttons on the left. It can’t seem to connect to my core, which is in the flashing blue mode. Here’s a pic in case there’s something obvious I’m missing: http://i.imgur.com/dyGA0Eb.png

I’m on Windows 7 SP1.

I think i have the same problem but the first time i click the compile button after i start Spark Dev i got this error massage (se picture)
Then nothing happens when i click on the compiler or flash buttons. If i use Spark Build it’s work fine.
I’m on a OS X 10.10

Actually, I’m trying it again, and it seems to be working a bit better now. The compile button now just tells me I have no errors, but it still can’t connect to my core. Is that a product of the wifi network I’m on, or should I be able to use this program even if my core can’t connect to the wifi network?

@stevethesquid - The Spark Dev IDE still uses the cloud functions to do compilation and flashing of the Spark Core. If you were having problems with the programming over the air before, it’s likely that you will still experience these problems. What you may need to do is compile and flash everything locally. There are instructions in the Spark firmware repository for getting it set up. It looks like @suda is or was working on a local DFU flash version of the IDE at some point.

@pellson60 - This is a known bug. You can track the progress of the bug report in this issue in the GitHub repository.

@stevethesquid it looks like you tried to compile code without saving it to a file. It’s something Arduino IDE does but isn’t’ supported in Spark Dev yet.

@pellson60 try moving your code into parent directory (“SPARK_IO”). This bug should be resolved in next release.

Is that a product of the wifi network I’m on, or should I be able to use this program even if my core can’t connect to the wifi network?

Your core needs to be connected to Spark Cloud (breathing cyan) to be flashed via Spark Dev.

It looks like the compile and flash works now, but the program will not start on the Spark Core. I used both cloud and the the dfu-util. If i use the Web IDE the program will start on Spark Core.

I really like dfu-util.

For the bug referenced earlier, the code needs to be in a dedicated directory void of other, non-project-related files. If you’re lazy like me and try to compile a single file on the desktop, it will break. I updated the docs and issued a pull request to make it more obvious.

I see that you have two .ino files in your project. To work compile correctly, project should contain only one .ino file. Could you try removing one of them?