SoM eval board + humidity/temp sensor issue

Hello Everyone,

I’ve been attempting to setup the “Grove DHT11 temperature and humidity sensor” with my SoM eval board however have been facing few issues. I followed a simple tutorial posted on Particle’s website, linked here. However, after following this, I was able to compile and flash the code and firmware to the board, but did not receive any humidity or temperatures in events. I do have my sensor plugged into J10 (A1) however nothing is being reported. Also, nothing in custom data was being reported either. I’m pretty stumped here.

You should uncomment the statement in loop() and then monitor the USB serial debug output to see if the problem is with the sensor, data, or publishing.

Thanks for the response! It’s definitely something wrong with the sensor, data or publishing then because I had uncommented that…


In lib/Grove_Temperature_And_Humidity_Sensor/src/Grove_Temperature_And_Humidity_Sensor.cpp, try uncommenting this block of code and see what the values look like in the USB serial log:

	Serial.println(j, DEC);
	Serial.print(data[0], HEX); Serial.print(", ");
	Serial.print(data[1], HEX); Serial.print(", ");
	Serial.print(data[2], HEX); Serial.print(", ");
	Serial.print(data[3], HEX); Serial.print(", ");
	Serial.print(data[4], HEX); Serial.print(" =? ");
	Serial.println(data[0] + data[1] + data[2] + data[3], HEX);

If you are doing a cloud compile, also remove this from to avoid having the released library take precedence over your modified library. This is not necessary for local compiles.


Just tried this yet I’m still not getting anything related to “hum” or “temp” on both USB serial and cloud events…