[SOLVED] Unable to install particle-cli on Windows 10


#1

[SOLUTION]

Installed using the Particle CLI installer

[ORIGINAL POST]

I was working fine on Windows 7 yesterday. But I am trying on another laptop with Windows 10 today and I am unable to install particle-cli.

Node is already installed so is npm. node -v gives v0.12.2. npm -v gives 2.7.4 .

When I try npm install -g particle-cli it gives
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

serialport@3.1.2 install C:\c\Users\sandi.node\node_modules\particle-cli\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\c\Users\sandi.node\node_modules\particle-cli\node_modules\serialport\build\Release\serialport.node” is installed via remote
C:\c\Users\sandi.node\particle -> C:\c\Users\sandi.node\node_modules\particle-cli\bin\particle.js
particle-cli@1.16.0 C:\c\Users\sandi.node\node_modules\particle-cli
├── xtend@4.0.1
├── semver@5.3.0
├── cli-spinner@0.2.5
├── chalk@1.1.3 (supports-color@2.0.0, ansi-styles@2.2.1, escape-string-regexp@1.0.5, strip-ansi@3.0.1, has-ansi@2.0.0)
├── temp@0.8.3 (os-tmpdir@1.0.1, rimraf@2.2.8)
├── cli-table@0.3.1 (colors@1.0.3)
├── node-wifiscanner2@1.2.0 (os-locale@1.4.0)
├── glob@4.5.3 (inherits@2.0.1, once@1.3.3, inflight@1.0.5, minimatch@2.0.10)
├── form-data@1.0.0-rc4 (combined-stream@1.0.5, async@1.5.2, mime-types@2.1.11)
├── latest-version@2.0.0 (package-json@2.3.3)
├── inquirer@0.11.4 (strip-ansi@3.0.1, ansi-regex@2.0.0, ansi-escapes@1.4.0, through@2.3.8, figures@1.7.0, cli-width@1.1.1, run-async@0.1.0, readline2@1.0.1, cli-cursor@1.0.2, string-width@1.0.2, rx-lite@3.1.2)
├── request@2.74.0 (is-typedarray@1.0.0, oauth-sign@0.8.2, aws-sign2@0.6.0, forever-agent@0.6.1, tunnel-agent@0.4.3, caseless@0.11.0, stringstream@0.0.5, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, aws4@1.4.1, combined-stream@1.0.5, node-uuid@1.4.7, qs@6.2.1, mime-types@2.1.11, tough-cookie@2.3.1, bl@1.1.2, har-validator@2.0.6, http-signature@1.1.1, hawk@3.1.3)
├── hogan.js@2.0.0
├── when@3.7.7
├── binary-version-reader@0.4.0 (buffer-crc32@0.2.5, h5.buffers@0.1.1)
├── lodash@3.10.1
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.30)
├── moment@2.14.1
└── serialport@3.1.2 (bindings@1.2.1, commander@2.9.0, es6-promise@3.2.1, nan@2.4.0, debug@2.2.0, object.assign@4.0.4)

I don’t know how I can change the minimatch version ? Can anybody help me with this please ?


#2

That’s just a warning (hence the WARN keyword). Does the particle CLI not run on this computer when you enter the command particle in the command prompt? You might need to restart your command prompt.


#3

@harrisonhjones Thank you so much for the reply. I closed and re-opened command prompt. I even restarted the computer, still doesn’t work. I am getting:

'particle' is not recognized as an internal or external command,
operable program or batch file.

#4

Interesting. Please re-run the npm install -g particle-cli and post the entire console output. Let’s see what’s going on!


#5

This is what I got. After the warning it seems like it tries to install, but I am not sure what’s going on. I just tried closing the re-opening the command prompt and still doesn’t work.

npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
-
> serialport@3.1.2 install C:\c\Users\sandi\.node\node_modules\particle-cli\node_modules\serialport
> node-pre-gyp install --fallback-to-build

[serialport] Success: "C:\c\Users\sandi\.node\node_modules\particle-cli\node_modules\serialport\build\Release\serialport.node" is installed via remote
C:\c\Users\sandi\.node\particle -> C:\c\Users\sandi\.node\node_modules\particle-cli\bin\particle.js
particle-cli@1.16.0 C:\c\Users\sandi\.node\node_modules\particle-cli
├── xtend@4.0.1
├── semver@5.3.0
├── cli-spinner@0.2.5
├── temp@0.8.3 (os-tmpdir@1.0.1, rimraf@2.2.8)
├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, strip-ansi@3.0.1, has-ansi@2.0.0)
├── cli-table@0.3.1 (colors@1.0.3)
├── node-wifiscanner2@1.2.0 (os-locale@1.4.0)
├── glob@4.5.3 (inherits@2.0.1, inflight@1.0.5, once@1.3.3, minimatch@2.0.10)
├── latest-version@2.0.0 (package-json@2.3.3)
├── form-data@1.0.0-rc4 (combined-stream@1.0.5, async@1.5.2, mime-types@2.1.11)
├── inquirer@0.11.4 (ansi-regex@2.0.0, strip-ansi@3.0.1, ansi-escapes@1.4.0, through@2.3.8, figures@1.7.0, cli-width@1.1.1, run-async@0.1.0, cli-cursor@1.0.2, string-width@1.0.2, readline2@1.0.1, rx-lite@3.1.2)
├── request@2.74.0 (is-typedarray@1.0.0, aws-sign2@0.6.0, oauth-sign@0.8.2, forever-agent@0.6.1, tunnel-agent@0.4.3, caseless@0.11.0, stringstream@0.0.5, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, aws4@1.4.1, combined-stream@1.0.5, node-uuid@1.4.7, qs@6.2.1, mime-types@2.1.11, tough-cookie@2.3.1, bl@1.1.2, har-validator@2.0.6, http-signature@1.1.1, hawk@3.1.3)
├── hogan.js@2.0.0
├── when@3.7.7
├── binary-version-reader@0.4.0 (buffer-crc32@0.2.5, h5.buffers@0.1.1)
├── lodash@3.10.1
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.30)
├── moment@2.14.1
└── serialport@3.1.2 (bindings@1.2.1, commander@2.9.0, es6-promise@3.2.1, debug@2.2.0, nan@2.4.0, object.assign@4.0.4)

#6

There is a Windows Installer for CLI, I’ll try to find the link.

But for your attempt your node version is way too old - should be 4.x.x or later


Update:
Here’s the thread

and here the official site
https://www.particle.io/cli

and the actual installer
https://binaries.particle.io/cli/installer/windows/ParticleCLISetup.exe


#7

I would try @ScruffR 's suggestion, use the Particle CLI installer. If you want to keep with the node way I’d be happy to debug.


#8

@harrisonhjones The Particle CLI Installer worked for me. Thank you so much for the help.


#9

I was following this guideline and it says the Node has to be somewhere between 0.10. and 0.12. …


#10

That’s from some time ago, node 6.x.x should works as well.


#11

Great! Thank you so much.


#12