Issue in installing particle cli

Hello guys
I got these errors when I was trying to install the particle cli.
I’ve already installed the node.js v 0.10.0, Python 2.7.10, and Microsoft visual studio express 2013.

C:>npm install -g particle-cli
npm http GET https://registry.npmjs.org/particle-cli
npm http 304 https://registry.npmjs.org/particle-cli
npm WARN engine particle-cli@1.5.11: wanted: {“node”:"^0.10.0"} (current: {“node
”:“v0.10.0”,“npm”:“1.2.14”})
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/hogan.js
npm http GET https://registry.npmjs.org/node-wifiscanner2
npm http GET https://registry.npmjs.org/inquirer
npm http GET https://registry.npmjs.org/request
npm http GET https://registry.npmjs.org/cli-spinner
npm http GET https://registry.npmjs.org/serialport
npm http GET https://registry.npmjs.org/softap-setup
npm http GET https://registry.npmjs.org/moment
npm http GET https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/when
npm http GET https://registry.npmjs.org/xtend
npm http 304 https://registry.npmjs.org/chalk
npm http 304 https://registry.npmjs.org/request
npm http 304 https://registry.npmjs.org/inquirer
npm ERR! Error: No compatible version found: chalk@’^1.0.0’
npm ERR! Valid install targets:
npm ERR! [“0.1.0”,“0.1.1”,“0.2.0”,“0.2.1”,“0.3.0”,“0.4.0”,“0.5.0”,“0.5.1”,“1.0.0
”]
npm ERR! at installTargetsError (C:\Program Files\nodejs\node_modules\npm\li
b\cache.js:682:10)
npm ERR! at C:\Program Files\nodejs\node_modules\npm\lib\cache.js:597:10
npm ERR! at saved (C:\Program Files\nodejs\node_modules\npm\node_modules\npm
-registry-client\lib\get.js:138:7)
npm ERR! at Object.oncomplete (fs.js:93:15)
npm ERR! If you need help, you may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Windows_NT 6.2.9200
npm ERR! command “C:\Program Files\nodejs\\node.exe” “C:\Program Files\nod
ejs\node_modules\npm\bin\npm-cli.js” “install” “-g” "particle-cli"
npm ERR! cwd C:
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.14
npm http 304 https://registry.npmjs.org/serialport
npm http 304 https://registry.npmjs.org/hogan.js
npm http 304 https://registry.npmjs.org/node-wifiscanner2
npm http 304 https://registry.npmjs.org/moment
npm http 304 https://registry.npmjs.org/glob
npm http 304 https://registry.npmjs.org/when
npm http 304 https://registry.npmjs.org/xtend
npm http 304 https://registry.npmjs.org/cli-spinner
npm http 304 https://registry.npmjs.org/softap-setup
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! C:\npm-debug.log
npm ERR! not ok code 0

please any suggestion?
@kennethlimcp , @Dave , @ScruffR , @bko , @tjp , @Jack , @peekay123

@Ahmedsa1983, try the latest version of node.js (0.12.4).

2 Likes

Thanks @peekay123
I tried that at the beginning, but it didn’t work for me.

@Ahmedsa1983,

Would you mind trying this with node 0.10.36? If it still errors, could you again paste the output along with the npm-debug.log?

Thanks!

3 Likes

Thanks @nexxy
I installed it on a second PC that works on Win7 32 bit.