[Solved] Reset button does not work, need to do a factory reset

I can’t think of a time I’ve actually used the reset button, until today. I’ve only had to hold the mode button to add wifi credentials. I need to do a factory reset because something in the code that is on the core now is preventing reflashing (sits with breathing cyan but doesn’t respond OTA). I flashed the core to its current state and it did not respond to any API calls and a few minutes later tried to reflash with another known-working program and I get nothing. Using the spark command line I get the error: flash core got error: {“code”:“ECONNRESET”}

I can get slow flashing blue, fast flashing blue, and thats it. Any button sequence using the reset button does not work. I tried to resolder the button thinking its a cold joint (just reheated each joint), but no dice. Shorting the button terminals directly also does not produce the desired effect.

I’m stuck and need help.

I guess for a factory reset you don’t necessarily need the reset button.
Try unplugging the Core, then hold down the MODE button an replug the Core - this might do the trick too.

On the other hand, could it be that your RST pin is pulled high for some reason? This might interfere with the pulling low the RESET button would do - I guess.


Pin works… I guess I try to avoid the reset pin so much that I forget it’s there… Thanks!

I’m going to make this solved (thanks @ScruffR). If you have any additional comments @JackANSI feel free to reply to this thread!