[solved] Photon setup failure - new LED flashing sequence


#34

Another day…of frustration. Nope. All of them are continuing to exhibit the same problem.

For giggles, I removed another device from my account and then re-claimed it without issue.

Also, when I tried to claim one of the new devices via Particle Dev, the response was [object Object] – same as yesterday via the CLI.

Do I need to test to see if I can ping a particular server port? I’m aware of no changes here and, as I indicated yesterday, I also tried to claim one of the problem devices via a cellular modem with the same result.

Once again, it’s failing at “Verify device ownership”

Thoughts???


#35

Since we have an email thread going now, I’ll update that one :smile:


#36

I’ll let @BDub or whoever post any helpful/informative message. However, with his assistance my issues were finally resolved. Thanks Particle Gang!


#37

I am having the same exact problem with 4 out of the 5 Photons I received yesterday. I haven’t tried the 5th photon yet. I’ve had 20 other Photons, this is the first I’ve seen this problem. What was the fix?


#38

Can you tell us the version of firmware on some of these devices? That would help us verify if the cause is a known issue or not.

I suggest upgrading to 0.4.9 or later using particle-cli (but please find out the firmware version first before upgrading!)

After upgrading, put the device in DFU mode and clear the current key by flashing a 0 to location 34, like this:

echo -e "/x00" > zero
dfu-util -d 2b04:d006 -a 1 -s 34 -D zero

Note that you should only do this if the device has never successfully connected to the cloud.


#39

Mine all arrived with 0.4.9. @BDub can explain the weirdness about my 3 thinking they were Cores instead of Photons and how that may play into the whole issue.


#40

Yes. Mine are also all 0.4.9. Sounds like the same problem.


#41

The best route forward is to open a ticket, referencing this thread, and provide the device IDs.


#42

I have a Photon with firmware 0.4.7 on it that has been sitting not connected to the cloud in the Semi-automatic mode for a year now maybe. I’m trying to use this for something, but I keep getting this red blink pattern.

https://youtu.be/INEgKRxdxA0

I also have three old Spark Cores that do the same thing, but I’m not worried about them at the moment.

I’ve tried the Particle Key Doctor via the CLI but I do not know how to install the OpenSSL package, and I’m not sure that is what is needed or not.

My Photon ID is: 280034001447343338333633

The device has been claimed successfully in the past, and it was programmed via the online IDE, but it was many months ago on firmware 0.4.7.

Any advice?


#43

You could try updating its system firmware, and flashing Tinker again if you haven’t already.


#44

That definetly looks like the key issue and installing OpenSSL isn’t that hard :wink:
You can always use the CLI installer which will add that too.


#45

@Moors7 Trying that now. :smiley:

@ScruffR I used the new Windows CLI installer to install the latest CLI but it’s saying OpenSSL is not installed.

Is there a command I should use in the Node command window that will installe OpenSSL? If not how should I do it? I didn’t see a EXE program to install it on the OpenSSL Git page.


#46

I loaded the latest 0.6.0-rc1 firmware + Tinker on the Photon but I get the same error message on the Photon.

I tried to add the device to the Particle Cloud but it will not work because it’s not connected to the cloud.

Looks like I need to figure out how to install OpenSSl to use the key doctor function in the CLI.


#47

You can’t claim a device that’s not cloud connected, but didn’t you have that device claimed already?

OpenSSL does not need an installer. Just unzip it to a directory and add that to the path.
But CLI installer should add OpenSSL - have you uninstalled your previous version of CLI as mentioned here?


#48

@ScruffR @jvanier I just installed the Particle CLI on a different Windows 8 machine using the new Windows CLI installer and that went just fine.

I tried to run the Key Doctor function and I get these OpenSSL errors.

The Photon was connected, in DFU mode, and all other functions worked fine using the CLI. I have the latest 0.6.0_rc.2 installed.

C:\Users\User>particle keys doctor 280034001447343338333633
Found DFU device 2b04:d006
Found DFU device 2b04:d006
Error creating keys… Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c
"openssl genrsa -out 280034001447343338333633_rsa_new.pem 1024"
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

Make sure your device is in DFU mode (blinking yellow), and that your computer i
s online.
Error - Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c “openssl genrsa
-out 280034001447343338333633_rsa_new.pem 1024”
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

C:\Users\User>


#49

@ScruffR @jvanier

Should I try to install OpenSSL via Kenneth’s link in the old manual CLI install instructions or is the above error message a sign that something else is currently wrong?


#50

You can try Kenneth’s link to get yourself unstuck, but I’m rather positive the installer should work.
But that’s for @jvanier to confirm and look into why it’s not on your side.

BTW, have you tried restarting your machine after install (just for the superstitious ;-))


#51

Yes, go ahead and do that. The CLI installer does not currently install open ssl because I was not aware this external tool was needed. I will add it in a future version of the installer.


#52

My bad then @RWB, sorry for assuming wrong and sending you down the wrong path :blush:


#53

@jvanier @ScruffR

I used this trick to fix the Photon.

I tried installing OpenSSL via the windows installer linked in Kenneth’s CLI setup instructions, but I still get the same error message when trying to use the Keys Doctor via the CLI. Yes even after a full windows restart :smiley:

I just let the OpenSSL program install to the default chosen directory that the installer chose. Maybe it needs to be installed in a different path?

I have all Photons working now and three old Core’s that have the same key issue, but I’m not planning on using them for anything so I’ll just wait for the OpenSSL app to be added to the future CLI Windows installer before trying to fix those.