[SOLVED]Photon - reboot loop

Hi all.

New to all this so go easy on me! I’ve been building a project for a couple of weeks on a Photon and all has been going well. Unfortunately I turned it on today to deploy an application to it and it now appears to be stuck in a reboot loop.

All the lights are flashing so I have no idea what’s going on. Perhaps someone else will be able to decipher them:


I’ve tried pressing the reset button which doesn’t seem to help.

I’ve also tried doing a factory reset, but it just starts flashing yellow infinitely.

It’s connecting to the cloud each time it reboots as I can see lots of events for “device came online” in the Particle Dashboard. No other events though…

Any suggestions on what I should do would be hugely appreciated.

Thanks
Rich

That an SOS code, highlighting specific errors. To get a clue of what they might indicate, have a look at the docs over here.

Well… See the following… https://docs.particle.io/guide/getting-started/modes/photon/#factory-reset

Let me know if that helped.

2 Likes

Perfect! Didn’t realise it was an SOS code - couldn’t understand why all the colours were flashing. Booted into safe mode then used the cloud IDE to deploy a basic app - all seems to be working again :smile:

Thanks

1 Like